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Logger Pro Overview
Overview

The Logger Pro user’s guide is divided into four main sections: this
overview, a How To section, a Teacher’s Guide, and the Logger Pro
Reference. This Overview concludes with quick-start instructions for the
eager. Instructors using Logger Pro in the classroom will want to read
the Teacher’s Guide for helpful tips. The How To section explains
common operations with Logger Pro. You can read it in any order. The
Reference Section explains the function of all the menu items and how
to use them. On-line help is available: Choose Help from the Apple
menu (Macintosh) or the Help menu (Windows).
The Logger Pro tutorials are stapled separately from the user’s guide for
ease of duplication. We suggest that you read one or both of the
introductory tutorials to learn more about Logger Pro. One introductory
tutorial focuses on using a temperature sensor with Logger Pro, and is
written for integrated science, chemistry and biology students. The other
introductory tutorial uses the Motion Detector and is written for students
who will study motion. Additional tutorials teach more advanced skills
such as data analysis, curve fitting and defining new columns.
Initial software installation and the connection of the interface are
explained in the Teacher’s Guide. Refer to the troubleshooting chart in
Appendix A if you have problems. Detailed information for network use
can be found in Appendix B. Appendix C reviews the interfaces that can
be used with Logger Pro, and how to choose between them. A
comprehensive list of the sensors compatible with Logger Pro is in
Appendix D.
Some familiarity with the use of the Macintosh or Windows and
application software is assumed in this manual.

Logger Pro,
the LabPro, the Universal
Lab Interface and the Serial
Box Interface

Logger Pro, for use with the Vernier LabPro, the Universal Lab
Interface (ULI) and the Serial Box Interface, has been designed by Rick
Sorensen, Dave Vernier, John Wheeler, David Gardner, Dan Holmquist
and John Gastineau of Vernier Software & Technology, and by Ronald
Thornton and Stephen Beardslee at the Center for Science and
Mathematics Teaching at Tufts University. The design was implemented
by Stephen Beardslee, Nam Hoang, Mary Dygert, Chris Corbell and
Zachari Partridge. Version 2.1 revisions were made by Stephen
Beardslee, Chris Corbell, Mary Dygert, Garth Upshaw, Diane Whitfield,
and Jessica Fink.
Logger Pro is copyrighted by Vernier Software & Technology and Tufts
University. You are permitted to make as many copies as you wish of the
Logger Pro software, the User's Manual and the Tutorials for use in your
own high school, middle school, or college department. You may use
Logger Pro on networks within your school or department at no extra
cost. Our site license also permits your students to load a copy of Logger
Pro on their home computers.
The Logger Pro manual is copyright ©2000 by Vernier Software &
Technology. John Gastineau wrote this manual, version 2.1 revisions by
Jim McBride. Macintosh is a registered trademark of Apple Computer,
Inc. Microsoft, Windows, Windows NT, and Win32s are either registered
trademarks or trademarks of Microsoft, Inc.

Logger Pro
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Logger Pro Quick Start
Purpose
Install software
Attach interface and sensor

This section is provided for those who do not read software manuals. It
outlines the essential steps to get started with Logger Pro.

y Insert the CD into your computer and run the installer program.
y Accept the default suggestion for file location.
y Attach a LabPro, a ULI or a Serial Box Interface to the computer
using the supplied cable. On the Macintosh you can use any serial
port, including the modem and printer ports. On the PC you can use
any of the COM1, 2, 3 or 4 serial ports. LabPro users can also use the
USB port and cable on an USB-equipped PC or Macintosh.

Start up Logger Pro

y Attach the power adapter to the interface and to a source of 115VAC.
y Attach a sensor to the interface.
y Locate the Logger Pro icon and double-click on it, or use the Start
menu (Windows 95/98/NT). You should see the following screen on
your monitor unless you are using a LabPro and auto-ID sensor.

LabPro auto-ID

y LabPro users with auto-ID compatible sensors such as a Stainless

Steel Temperature Probe or a Motion Detector can skip the following
step, for Logger Pro will have already identified the sensor and is
ready to collect data.

Logger Pro
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Configure Logger Pro for
your sensor

y Choose Open from the File menu, and choose an experiment file

from the appropriate sensor folder. For example, if you will use the
Barometer, look inside the folder Probes and Sensors for the folder
Barometer for the barometer experiment files. Calibration is
automatically loaded with the experiment file.

Collect data

y Click

Adjust graph

You can adjust most features of the graph by double clicking the graph
and making changes in the resulting dialog box.

Collect on the screen. Logger Pro should begin plotting data in
the graph window.

Insert linear regression line

y First, select a portion of the graphed data by dragging across it.
y Then click on the linear fit button on the toolbar.

If you need more

If you need more information for using Logger Pro, remember that there
is a manual and extensive on-line help.
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Tutorial Overview
Purpose of tutorials

The Logger Pro package includes eight short tutorials for first-time
users, either students or teachers. They are suitable for reference or for
duplication and distribution to classes. First-time users should work
through one introductory tutorial and the advanced tutorials as needed.
The tutorials are bound separately from the manual for easy duplication.

Introductory tutorials

The first two tutorials, Temperature Measurement and Motion Detection,
are both introductions to using Logger Pro. All students can use
Temperature Measurement, while Motion Detection is intended for
physics or integrated science students.

Advanced tutorials

The remaining tutorials are intended to be read after either of the first
two tutorials are completed, and provide instruction on performing
specific tasks with Logger Pro. These tasks include

y analyzing data and changing what is graphed
y fitting curves to data
y saving files and printing or transferring data
y creating new columns for data
y temperature measurement using auto-ID
y Motion Detector use with auto-ID
y remote data collection

The advanced tutorials can be done in any order.
Preliminary setup

The tutorials assume that Logger Pro has been installed and an interface
(a LabPro, a ULI or a Serial Box Interface) is properly connected to the
computer. Installation instructions are located in the Teacher’s Guide.

Logger Pro
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How To
In the How To section you will learn to perform specific functions in
Logger Pro, such as using a new sensor or changing data collection
rates. You don’t need to read this section straight through—just jump to
the task you want to perform, and read that portion. The tasks are
organized in seven broad categories: graph appearance, sensor functions,
data collection options, non-graph windows, data analysis, data tables,
and saving and printing data.
If you have further questions, go to the reference section and read the
descriptions of the relevant menu items, or check the index for other
references.

Change Graph Appearance
There are many ways that you might want to change the appearance of
the initial graph. The range of the x or y axis might not be ideal. Or, you
might want to plot other quantities on each axis. You can change most
elements of the graph directly by clicking on them, so if you are not sure
how to change a given item, begin by clicking on it and see what
happens. Here are some things you can quickly change on a graph.
Change axis limits manually

Often you will measure some quantity and the plotted line will only fill a
portion of the screen. You can quickly change the range of values plotted
by clicking the numbers at the ends of the graph axes. Type a new value
and press enter.

Change axis limits
automatically

To make the plotted data fill the graph window for this particular
collection of data, click the Autoscale Once button on the toolbar.
To turn automatic scaling on for all subsequent collections of data
choose View Set Axes to Autoscale.

Æ

To change just the x- or just the y-axis limits, click on the desired axis.
You will see a dialog
box:
Choose the type of
scaling you want.
Autoscale Once will
set the axis limits so
the data just fill the
axis. The origin may
not necessarily be
included unless you
choose
Autoscale
from 0, in which case
the origin is always included. Manual scaling allows you to enter the
minimum and maximum limits manually. The choice made here will
determine how Logger Pro scales a new graph.
Zoom in on a graph

To enlarge a portion of a graph to fill the screen, drag across the
desired area with the mouse, leaving a rectangle on the graph
enclosing the area of interest. Then click on the Zoom In button
on the toolbar. If you don’t like what you see, you can reverse the
action by clicking the Undo Zoom button.

Logger Pro
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The Zoom Out button will double the range of both the x and y
axes. It does not undo a Zoom In—Undo Zoom does that.
Scroll to a new portion of
graph without rescaling

Sometimes the plotted data will extend off the screen. The arrows at the
ends of the vertical and horizontal axes can be used to scroll across the
data. Using the scroll arrows is equivalent to changing both extremes of
the axis limits at the same time while maintaining the same interval
between extremes.

Change what is plotted

The default plot will usually be the sensor output as a function of time or
a prompted input. You may want to plot some other quantities. Click
either on the x- or y-axis label to get a check box list of all the possible
quantities for plotting. Some combinations will not be useful. If you
don’t see what you want to plot, you may be able to create a new column
of data based on the raw data. See create new columns below. Once
you’ve defined a new column you can plot it.

Graph two or more sensors
simultaneously

You can plot data from multiple sensors either on a single graph or on
separate graphs. To use a single graph:

y Click on the y-axis label and select all the sensors you want to plot
together. Click on OK

To use several different graphs, you need to create the needed number of
graph panes:

y Choose Graph Layout from the View menu.
y Click on the layout with the desired number of panes.
y For each graph click on the axis label for a list of available columns
for plotting. Choose the column of the desired sensor.

Plotting one sensor versus
another sensor

Sometimes it is appropriate to plot the value of one sensor versus
another. For example, you might want to graph pressure as a function of
temperature. Once Logger Pro is set up to simultaneously take data for
the two sensors, click on the axis labels to select the appropriate
quantity. A graph does not need to include time.

Change the units displayed

The axis labels are shown with physical units whenever they are
available. When you set up a new sensor, you can enter the desired units
at the same time that you perform calibration. For more information see
sensor setup below.

Change other graph options

If you double-click on a graph, you will get a dialog box that allows you
to change a number of graph options. Brief descriptions follow; for
additional information see Logger Pro reference.
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The following functions are found on the Graph Options dialog. Double
click a graph to open this dialog box.
See data points directly (point
protectors)

Select point protectors as desired. A point protector outlines a data point.
You may want to outline every 5th or 10th point to keep the graph from
getting crowded.

Add/remove a legend

Adding a legend opens a floating box holding a key to the plotted data.

Connect data points

Select the Connecting Line option to connect data points with lines.
Without this option selected individual data points are visible.

Bar graph

When this option is selected a line is drawn from the horizontal axis to
each data point, creating a bar graph. You can control the width in
pixels. Setting the 3D checkbox adds simulated depth to the bars.

Add/remove the grid

Select or deselect the grid as desired. You can also adjust the line style
and color of the gridlines in this dialog box.

Graph title

Select or deselect the Graph Title option as desired. Logger Pro attempts
to create a title for a graph based on the axis labels, but you can override
the automatic title by entering text in the Graph Title field.

Logger Pro
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Configure Sensor Functions
The best way to set up Logger Pro for a particular sensor is to open an
experiment file. Logger Pro comes with experiment files for each
Vernier sensor and for the books Physics with Computers, Biology with
Computers, Chemistry with Computers, Physical Science with
Computers, Water Quality with Computers, Middle School Science with
Computers, Nuclear Radiation with Computers, Real Time Physics, and
Tools for Scientific Thinking. Most of these books are available from
Vernier Software & Technology. The files load an appropriate
calibration, set data collection parameters, and prepare Logger Pro for
experiments with that sensor. Even if you want to use your own custom
configuration, these files are good starting points.
Auto-ID (LabPro only)

The LabPro interface can automatically identify compatible sensors.
When Logger Pro is launched an appropriate experiment file will be
loaded automatically. You may need to adjust data collection mode and
parameters to suit your particular experiment. Or, you can ignore the
auto-ID function and open an experiment file as discussed below.

Open an experiment file

Choose Open from the File menu. Initially you will see a list of folders
corresponding to the various books, the tutorials, and specific sensors.
Choose the experiment file from the scrolling list that matches your
sensor and application.1 If you are not working from one of the Vernier
books, we suggest that you open an experiment file listed by the sensor
name. Logger Pro is now ready to acquire data with the selected sensor.

Perform a
complete configuration

To set up Logger Pro for a particular sensor and experiment without an
experiment file, or to add additional sensors to that supported by an
existing experiment file, you will need to specify the sensor, input, and
calibration file to be used in the Sensor Properties dialog. As an
example, here is the way to configure Logger Pro for a temperature
sensor. Calibration instructions follow the initial setup.

y Attach the sensor to a physically compatible port.
y Choose Sensors… from the Setup menu or click on the interface icon
in the toolbar. (

or

)

You will see the dialog box or a similar one as depicted on the next page,
depending on the interface you are using.

1

You may need to navigate through the directory structure of your hard disk to
find the experiment files. If the Logger Pro Preferences are properly set you
will immediately see the experiment files when you choose Open.
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Next,

y Click on the port to which you attached the sensor. For example, CH1
if you attached the temperature probe to that input.
y Choose the sensor name from the Sensor scrolling list.
y Choose the desired calibration file from the Calibration scrolling list.
Some sensors have several possible ranges or units choices. In most
cases you will use the default calibration.

In most cases you do not need to manually calibrate, for the supplied
calibration will be adequate. If you do not need to perform a new
calibration for the sensor, click on OK. You are ready to acquire data. In
cases where you do want to calibrate a sensor for additional accuracy,
follow the instructions immediately below.
Calibrate a sensor

To calibrate a sensor you must have another way of measuring the sensor
quantity. For instance, with temperature sensors you will need a separate
thermometer as well as water baths of different temperatures.
To perform a new calibration,

y Choose Sensors from the Setup menu if the Sensor Setup window is
not already open.
y Click on the Calibrate tab at the top of the resulting dialog box.

Logger Pro

19

Teacher’s Guide

First calibration point

y Click on the input or inputs to be calibrated. The selected inputs will
be outlined in black.
y Click on Perform Now.
y Allow the sensor and the thermometer to stabilize at the first calibration temperature. You can determine this by waiting until the
input readings stabilize. The input readings are the raw voltage
signals from the sensor, and it is the relationship between the voltage
and temperature that is being determined by this calibration.

Second calibration point

Save calibration

y Read the thermometer, and enter the reading in degrees into the
Value 1 field.
y Click on Keep.
y Move the sensor and thermometer to the second bath and allow them
to stabilize at the second calibration temperature.
y Enter the thermometer’s reading in degrees into the Value 2 field.
y Click on Keep.
You may want to save the calibration result for later use.
Saving an experiment file most easily saves the calibration information.
The calibration information, along with all other Logger Pro settings, is
loaded when the experiment file is opened. We recommend that you use
the experiment file method of saving calibration and experiment setup.
If the calibration should be generally available any time a user selects
that sensor in the Sensor Setup dialog, then save the calibration
separately by clicking on the Save button.

y Click on Save to record the calibration to disk for later use, or click
on OK to use the calibration only temporarily.

Calibration files are saved to the calibration directory set in the Logger
Pro preferences.

Æ

Remove a sensor

To remove a sensor from a configuration so that data are no longer
collected from the input, choose Delete Column
(sensor name) where
sensor name is the sensor you want to remove. You can also click on the
Sensor Setup button (
or
), then click on the input
to be freed, and choose None from the sensor list.

20

Logger Pro

Teacher’s Guide

Configure Data Collection Options
The easiest way to configure Logger Pro for a particular data collection
mode is to open the appropriate experiment file. Experiment files for all
compatible sensors and common data collection modes are supplied with
Logger Pro. You can also configure Logger Pro manually. Instructions
for manual configuration follow.
Collect data in real time

Choose Data Collection from the Setup menu. You will see this dialog
box.

Select Real Time Collect from the scrolling list. In this mode data are
collected continuously at the rate indicated and for the time interval set
on the Sampling tab. To modify these settings, click on the Sampling
tab.
Collect data repeatedly

To start new data collection runs repeatedly, select Repeat from the drop
down menu. Logger Pro will collect a data run, pause for a moment, and
then collect another run, overwriting the previous run. To stop data
collection, click on the Stop button on the Toolbar. If you miss the end of
a run you want to keep and Logger Pro starts taking data again, click on
stop, then choose Undo Collect from the Edit menu to return to the
previous run.

Logger Pro
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Set sampling speed
(data collection rate)

In the Data Collection Sampling tab set the time units you want and the
Sampling Speed, i.e., the number of points collected each second,
minute, or other time interval. Sampling speed is a trade-off; too fast a
speed yields unwieldy data sets, while too slow a collection rate will
miss important experimental details. The maximum sampling speed
depends on the interface used and the number of input channels. Logger
Pro can collect at most 30,000 points in one input channel.

Set experiment length

Set the total time of data collection for Real Time Collect, Repeat and
Selected Events modes in the Data Collection Sampling tab. You can
also set the experiment length by changing the maximum time axis label
to the desired value.

Set over sampling

The setting for Over Sampling determines how many measurements will
be taken for each reported point. For example, if the sampling speed is
10 samples/second and over sampling is set to 5 points, readings will be
taken 50 times a second (evenly spaced in time) and each 5 will be
averaged to yield a single data point. A message explaining the amount
(if any) of over sampling which can be applied to the current
combination of probes and data rate appears under the entry box. Only
analog sensor readings can be averaged. Digital readings, such as from
the Motion Detector, cannot be averaged.
A different approach is to define a new, smoothed data column as a
function of an existing column using the smooth( ) function. Smoothing
differs from over sampling in that smoothing acts on an existing data
column and does not reduce the number of data points. To change the
number of points used in smoothing choose Options in the Experiment
menu. The subsequent dialog box allows you to vary the amount of
smoothing. Excessive smoothing may obscure important details in the
data.
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Trigger data collection

The Triggering tab of the data collection dialog allows you to set trigger
conditions for data collection. When triggering is enabled in the
checkbox and the Collect button is clicked, Logger Pro waits until
trigger conditions are met to collect data. If multiple sensors are in use,
data collection will begin when the trigger condition is met on any one
of the inputs. Only analog sensors can be used for triggering.

When using the LabPro interface and a fast rate data collection, the
dialog is slightly different to account for the fact that LabPro uses edge
triggering at these rates.

Logger Pro
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Collect data point by point
(prompted)

To collect discrete data points rather than a steady stream of data, choose
Data Collection from the Setup menu. Choose either Events with Entry
or Selected Events from the drop down menu. In either mode, after the
Collect button is clicked a Keep button appears. A data point is recorded
whenever the Keep button is clicked; in addition if the mode is Event
with Entry you are prompted to enter values for a new data column. For
example, you might enter a volume, concentration, or trial number. The
labels for the prompted column are entered in this dialog box.

Collect photogate data

To collect photogate or Smart Pulley data, choose Data Collection from
the Setup menu. Choose Photogate Timing from the drop down menu on
the Mode tab. It is not necessary to set any inputs using the Setup Sensor
dialog. The photogate mode supports seven methods of collecting data.
To see these modes click the Sampling tab:

The available modes are: Motion Timing, Gate Timing - One Gate, Gate
Timing - Two Gates, Pulse Timing, Collision Timing, Pendulum Timing,
24
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and Gate and Pulse Timing. Each mode is described below. The diagram
following these descriptions will help you visualize the various modes.
Motion Timing

The Motion Timing mode uses a photogate or Smart Pulley connected to
the digital input DG1 only. During operation, times are recorded as
leading opaque edges of a "picket fence", bar tape, or a pulley spoke
pass through the photogate beam. These times are displayed in a data
table. More importantly, if you enter the distance between the leading
edges of the opaque bands in the Length of Object field, the program can
analyze the times, and calculate velocities, displacements, and
accelerations.

When a picket fence or bar tape is used, the width of each of the bands
(d in the figure above) should be at least 0.5 cm. The distance between
the leading edges should be at least 3 cm or larger if the picket fence is
to be moving rapidly (for example in a free fall experiment). A closer
spacing can be used if the object will be moving slowly; for example, on
an air track glider.
Gate Timing - One Gate

This mode uses one photogate connected to DG1. The timing will begin
when this photogate is first blocked. The timing will continue until the
photogate is unblocked. The duration of the interruption is thus timed. If
the length of the object is entered in the Length of Object field, the
velocity is calculated.

Gate Timing - Two Gates

Gate Timing with Two Gates works with photogates connected to DG1
and DG2. It is assumed that the photogates will be interrupted in
sequential order. The time measured at each photogate is reported in a
different column in the data table. If the length of the object is entered in
the Length of Object field, the velocities are calculated.

Pulse Timing

Pulse Timing refers to the measurement of the time from the blocking of
one photogate until another photogate is blocked. The timing will begin
when the photogate in DG1 is first interrupted. It will continue until the
photogate in DG2 is interrupted. If the distance between the photogates
is entered in the Distance Between Gates field, the velocity is calculated.

Collision Timing

The Collision Timing mode uses photogates attached to DG1 and DG2.
It differs from other timing modes in a number of ways. It allows both
photogates to time independently and times are listed in the data table in
columns, according to the gate at which they were measured. Other
modes list times in columns, in order as they were measured. A data
table of results measured in this mode will look like this:
Times Listed By Gate:
Delta T1
Delta T2
(s)
(s)
0.5552
0.7872
0.4332
3.4437
1.0012
1.2623
For each gate, the times are listed in the order in which they were
measured. In the example above, photogate #1 was blocked 4 times and
photogate #2 was blocked twice.
Notice that the Collision Timing mode is similar to the Gate Timing Two Gates mode, without any restriction on the order in which the two
gates are blocked. If the length of the object is entered in the Length of
Logger Pro
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Object field, the velocities are calculated. This mode is specifically
designed for studying air track collisions. It allows the study of virtually
any possible collision.
Pendulum Timing

The Pendulum Timing mode uses a photogate attached to DG1. The
timing will begin when the photogate is first interrupted. The timing will
continue until the photogate is interrupted twice more, so that you get
the time for a complete swing of a pendulum or other oscillating object.

Gate and Pulse Timing

This mode requires two photogates. The first timing is of the duration of
the interruption of the photogate #1. The second timing begins when
photogate #1 is unblocked. This timing continues until photogate #2 is
blocked. The third timing is of the duration of the interruption of the
beam in photogate #2. If the length of the object is entered in the Length
of Object field, the velocity is calculated. The acceleration is calculated
from the change in speed.
Note that the ∆ time used in the acceleration calculation is the time
between the mid-points of the first and last intervals (½T1 + T2 + ½T3).
The following diagram illustrates the various photogate timing modes.
For each line, the vertical axis represents the photogate state with
unblocked as high, and the horizontal axis represents time.

Collect radiation data

To collect data from the Radiation Monitor or the Student Radiation
Monitor, open an experiment file for the Radiation Monitor. Connect the
monitor to the DG 1 port of the ULI or the DIG/SONIC 1 port of the
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LabPro. It is not necessary to set any inputs using the Setup Sensor
dialog. To adjust data collection parameters, choose Data Collection
from the Setup menu. Click the Sampling tab to set the experiment
length and the length of one counting interval. Logger Pro will report the
number of pulses received during each counting interval.
There are two Radiation Counting methods: Real Time Collect and
Events with Entry, chosen on the Sampling Tab. In Real Time Collect
mode Logger Pro will count for successive counting intervals until the
set experiment length is reached. In Events with Entry, Logger Pro will
count for successive counting intervals, but will not record a value until
the Keep button is pressed. At that time an entry dialog will be displayed
for the user to enter a value. Press Enter or click OK to complete the
entry. A dialog will pause the collection until you are ready to start the
next collection period by clicking Continue. Click Stop (or Stop
Collection) when the desired number of points have been collected.

Correct entries

You can correct mistakes in the prompted column created by Events with
Entry mode. First, collect any additional data required in the run. Then,
click the Stop button. In the Data Table Window, click on the cell you
want to change. Type the new value. Click on another window to
confirm your entry, or press Enter to continue corrections in the cell
below. Sensor data cannot be modified, just as a scientist never erases
data in a notebook. To ignore sensor-collected data, select those rows in
the data table window and choose Strikethrough Rows from the Edit
menu. To restore any ignored rows, select the rows in the data table and
choose Restore Rows from the Edit menu.
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Sort data

If the column used for the
horizontal axis is not in
ascending or descending order
the graph will not be drawn
correctly when connecting lines
are enabled. This can easily
happen when the column
consists of prompted entries.
Choose Sort Data from the Data
menu, choose the column by
which to sort, click ascending or
descending as desired, and click
OK.
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Remote Data Collection (LabPro only)
LabPro can collect data without being attached to a computer. The ULI
and Serial Box interfaces do not perform remote data collection. Having
a computer or calculator attached to LabPro is preferable when possible,
because it provides much more flexibility in your data collection and
provides a screen for immediate feedback of your results. There are
times, however, when disconnecting the computer from LabPro to
collect data is useful. For example, remote data collection is perfect for
gathering acceleration data on a roller coaster. For these times, there are
three methods available.
Quick Setup Method

1. Set up LabPro for remote
data collection
2. Collect data

Using the Quick Setup Method, you can collect data with LabPro, then
retrieve it using a computer running Logger Pro. You can collect up to
99 points without using a computer to set up data collection. This
method will work only with auto-ID sensors.

y Connect your auto-ID sensor(s) to LabPro.
y Press the QUICK SETUP button. A beep and a flash of the yellow
LED will verify setup.
y When you are ready to collect data, press the START/STOP button.
You will hear a beep indicating that data collection has begun. The
green LED will blink each time a reading is made.

y When

data collection is completed, the yellow LED will flash
briefly.2 You do not need to press the START/STOP button to end data
collection. (You can, however, stop data collection early by pressing
the START/STOP button before data collection is finished.)

3. Retrieve the data

y First connect LabPro to your computer.
y Start Logger Pro (if it is not already running).
y Select Retrieve Data on the “LabPro Has Data” dialog if it appears,
or choose Retrieve Data from LabPro from the Remote menu.
y The data will be transferred from LabPro into Logger Pro. You may
need to use Data/Column Options to change the label and units.

Setup for Real Time Collect
Method

1. Set up LabPro for remote
data collection

Using the Set Up for Real Time Collect Method, you will use a
computer to set up LabPro, detach it for a real time data collection, then
reattach it to the computer to retrieve the data. This gives you more
flexibility than the Quick Setup Method. With this method, you can (a)
use any sensors (not just auto-ID), (b) control the time between samples,
and (c) control the number of data points collected (up to 12,000 total
for all channels).

y Set up the sensors, LabPro, and Logger Pro just as you normally
would to collect data in Real Time Collect mode.
button, select Set Up LabPro from the
y Instead of clicking the
Remote menu.
y Follow the on-screen instructions to finish setup. The yellow LED
will remain on, indicating that LabPro is ready for data collection.
y Save the experiment file, so it can be used to later retrieve the data
from LabPro.
y When you are ready to collect data press the START/STOP button.
Collect

2. Collect data

The green LED will blink each time a reading is made.

2

The duration of data collection will vary from sensor to sensor.
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y When data collection is complete, the yellow LED will flash briefly.
You can also stop data collection early by pressing the START/STOP
button before data collection is finished.

3. Retrieve the data

y Reconnect LabPro to a computer.
y Start Logger Pro (if it is not already running) and open the
experiment used previously for setup.
y Select Retrieve Data on the “LabPro Has Data” dialog if it appears,
or choose Retrieve Data from LabPro from the Remote menu. The
time it takes for the data to be retrieved may be considerable
depending on the number of points collected remotely.

y The data will be graphed on the screen and ready for further analysis.
Setup for Selected Events
Method

1. Set up LabPro for remote
data collection

Using the Set Up for Selected Events Method, you will use a computer
to set up LabPro, detach it to collect individual data points, then reattach
it to retrieve the data. With this method, you can use any sensors (not
just auto-ID), and collect individual data points whenever you press the
START/STOP button.

y Set up the sensors, LabPro, and Logger Pro just as you normally
would to collect data using the Selected Events mode.
button, select Set Up LabPro from the
y Instead of clicking the
Remote menu.
y Follow the on-screen instructions to finish setup.
y Save the experiment file, so it can be used to later retrieve the data
from LabPro.
y Every time you press the START/STOP button, LabPro will collect
Collect

2. Collect data

one data point. The green LED will flash with each reading. Repeat
as often as you want, up to 99 readings.

3. Retrieve the data
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y Reconnect LabPro to a computer.
y Start Logger Pro (if it is not already running) and open the
experiment used previously for setup.
y Select Retrieve Data on the “LabPro Has Data” dialog if it appears,
or choose Retrieve Data from LabPro from the Remote menu.
y The data will be graphed on the screen and ready for further analysis.
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View Other Window Types
The Windows menu contains commands that add or replace windows to
the Logger Pro Screen. Since each new window reduces the screen area
available for the existing windows, the precise action of the window
commands depends on the currently active window. New Tall Window
halves the width of the current window and creates a new window of
vertical orientation of the selected type. Similarly, New Window Wide
halves the height of the current window and creates a wide window of
the selected type. Replace Window replaces the selected window with a
window of the newly selected type.

Æ

Graph

Choose New Tall Window
Graph from the Window menu. A new
graph window will be created. Note that it may be more useful to create
a new pane in a graph window instead since less screen area is required.
See Graph Layout in the View menu of Logger Pro Reference for more
information.

Table

Choose New Tall Window
Table from the Window menu. A new data
table window will be created.

FFT

Æ

FFT Graph
FFT Table

Histogram

Æ Histogram

Graph
Histogram
Table

Text

Æ
Choose New Tall Window Æ FFT Æ FFT Graph to create a new graph

window holding the FFT (Fast Fourier Transform) of the current data.
Once you have created an FFT Graph, you may choose FFT Table to
open a new data table window containing the numerical FFT
information. Double click on either FFT window type to adjust its
properties.

Æ

Æ

Choose New Tall Window
Histogram
Histogram Graph to create a
new histogram window representing the current data. Once you have
created a Histogram Graph, you may choose Histogram Table to open a
new data table window containing the numerical histogram data. Double
click on either histogram window type to adjust its properties. The bin
width may be changed in the Axis Options tab of the Histogram Options
dialog box.

Æ

Choose New Tall Window
Text from the Window menu. A new
window will be created for text entry. You can use this window for
laboratory instructions, information about the experiment, or other notes.
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Æ

Meter

Choose New Tall Window
Meter from the Window menu. A dialog
box will open which allows you to select the data columns to be
displayed in a digital meter window. Then a new window will be created
containing the selected digital readouts. Double-click on the meter
window to change which quantities are displayed.

Strip Chart Graph

A chart-recorder-like mode for graph windows is activated
automatically for sampling speeds less than or equal to 250 pts/s
whenever there are two graph windows open and one graph window is
scaled to less than the experiment length. This works for both collection
and replay.

Æ

Choose New Wide Window
Graph from the Window menu. A graph
window will appear below the original graph window. Click on the new
graph’s x-axis maximum value and change the number to a value smaller
than the original value. As data is collected and the graph plot reaches
the end of the x-axis, the graph will automatically scroll to keep up with
the data collection for the length of the experiment. Due to differences in
computer performance, if the strip chart graph stops before the end of
the experiment length try changing the collection rate and x-axis
maximum.
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Analyze Data
Read values from cursor

As you move the mouse cursor around the graph the coordinates of the
point directly under the cursor point appear in the rightmost area of the
status bar at the bottom of the main Logger Pro window.

Read delta values between
two points

You may click, hold, and drag the mouse cursor from one point to
another on the graph to get the delta between two points. The horizontal
and vertical distance (∆x and ∆y) between the two points is displayed
next to the mouse cursor position in the rightmost area of the status bar
at the bottom of the main Logger Pro window.

Read values from graph

Choose Examine from the Analyze menu. A floating box will appear,
accompanied by the numerical value at the mouse pointer position. As
the mouse cursor is moved across the graph, the readout will change and
the data table will scroll to highlight the associated numerical values.

Display tangent lines

To draw tangent lines and read the slope of those lines, choose
Tangent from the Analyze menu (or click on the tangent line
button on the toolbar) and move the pointer to the place where you want
the slope. A floating box will appear, containing the numerical value of
the data and the slope of the tangent line at the pointer position. The
number of points used in calculating the tangent may be set by choosing
Options from the Experiment menu.

Compare runs

Often you will want to compare two similar runs of collected data. When
you get the first useful run, choose Store Latest Run from the Data
menu. Now you may take additional data and the stored run will not be
lost. The data will be retained through subsequent data collections, and
can be displayed or hidden as desired. Stored runs are numbered
sequentially. Any number of runs can be stored, and will be saved when
you save an experiment to disk.
The Data menu has four more relevant functions. Hide Run will
temporarily remove the selected run from the graph, Show Run will put
it back, Rename Run allows changing the displayed name of a selected
stored run, and About Run shows the timestamp of the data and allows
you to enter notes about the run. Using the Hide/Show functions you can
superimpose any desired set of runs.

Fit a line to data
(linear regression)

To fit a straight line to your data, select the desired portion of the
data by dragging across it. Next, choose Linear Fit from the
Analyze menu (or click on the linear regression button on the toolbar). A
straight line will be fit to the indicated data, and the slope and intercept
information will be displayed in a floating box. Displayed precision can
be adjusted by double-clicking on the floating box to open a new dialog
box.
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Fit functions to data

To fit more complex functions to your data choose Automatic
Curve Fit from the Analyze menu (or click on the Automatic Curve Fit
button on the toolbar). You will see the following dialog box. To fit to
just a part of your data, you must first select the desired portion of the
data by dragging across it.

Now choose a mathematical relation from the list at the lower left. You
may need to scroll through the list to find the appropriate function. The
polynomial choice also requires that you set the degree of the
polynomial. Next, choose the data set you want to use from the Perform
Fit On menu. Click on Try Fit to see the result. If you like, choose
another function or data column for another trial fit. You can also select
a different range of data by dragging across the graph region. Click on
Try Fit to see the new fit. Once you have a fit that you like, click on OK
to display the fitted curve on your graph. Click on Cancel to discard all
fits. The Save button will place the fitted curve on the main graph
window without closing the dialog box.
Manual Fit
(Model Data)

To superimpose a function over your data, make a graph active by
clicking on it once. Select Manual Curve Fit from the Analyze menu. In
the dialog box select a function. Adjust parameters as needed to fit the
function to your data.
Note that poorly chosen parameters may make the function miss the
graphed region entirely. In this case it is difficult to adjust the parameters
by trial and error. You may want to select parameters carefully so that the
function matches the data at the y-intercept, and adjust values from
there.

Change Displayed Precision
of Fit Parameters

You can adjust either the number of significant digits or the number of
decimal places used in displaying fit statistics and parameters. After you
have completed a fit, double-click on the floating box containing the fit
information. A floating box options dialog will open, allowing you to set
the line color, line style, fit coefficients displayed, and their precision.
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Interpolate points

To interpolate between data points, first fit a function to a range of data.
Then choose Interpolate from the Analyze menu. The floating box for
the curve fit will expand to show the coordinates of points along the
fitted curve. Move the mouse pointer to the place you want to
interpolate.

Perform an FFT

To perform an FFT on the entire data sequence, choose New Tall
Window
FFT
FFT Graph from the Window menu. You can also
use New Wide Window. Double click on the FFT window to adjust its
parameters.

Æ
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Perform Data Table Functions

Change what runs appear in
the data table

You can control what is displayed in the Data Table Window. Double
click on the data table to change table options and click on the Table
Layout tab. You will see this tabbed dialog box.

Choose the table layout you need. The choices allow you to display all
columns from all runs, just a single run, or just one column from all
runs. You can further control what is shown in the data table by hiding
individual columns in the Column Options dialog found in the Data
menu, or by double-clicking a column header.
The Font Options tab shows a dialog in which you can choose display
font and size for the data table.
Change a column’s name,
color, width, or digits
displayed

Double clicking a column heading or the Run heading will open the
Column Options dialog, allowing you to change the column name,
width, color, or digits displayed. Double clicking the Run header will
allow you to choose a column from a list; double clicking a column
header directly will take you to the Column Options dialog for that
column.

36

Logger Pro

Teacher’s Guide

In the Column Options dialog you can change the column’s name, color,
decimal places displayed, and width. If you click in the box for
Propagate Changes, all runs for that column will be affected. Hide
Columns will conceal the column in the data table. You can choose to
apply the new point protector to all columns of that run, all runs for that
column, or that column and run only.
Calculate new values from
raw data (new columns)

Calculated data columns—an
example

As Logger Pro gathers data from a sensor, the data table fills in with
time and sensor readings. You can define rules for columns calculated
from the sensor readings much like you enter formulas in a spreadsheet.
The definition can be entered either before or after the data are collected.
These new columns can be graphed just like any other column, even as
data are being collected. The calculated columns can be used for a
variety of purposes, including graphing calculated data or data entered
from the keyboard. These are described in turn below.
As an example, let us convert temperatures measured in degrees Celsius
to degrees Fahrenheit. To get °F, we will need to multiply the raw data
from the Temperature Sensor, in °C by 9/5 and then add 32.
First, choose New Column from the Data menu. You will see this dialog
box, but without the entries you are about to make. Click on the Options
tab to be sure this pane is on top.
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Labels
To give this example column appropriate labels, enter Fahrenheit in the
label field and degrees F in the units field. The short label is used in
places where there isn’t room for the whole name; here, F would be a
good choice.
In this dialog box you can also make other choices for the new column
such as color for graphing. Or, you may want to not include this new
column in the data table. To hide it, click the Hide Column in Table box.
Next click on the Definition tab to see the rest of the dialog box and to
complete the column creation process.
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Equation
The Equation field is where you will build the formula that defines the
new column. In this example of finding °F, we need to enter in the
formula field 9/5*“Temperature”+32. (Because of the order of arithmetic
operators, no parentheses are needed, but you can use parenthesis as
desired to make the formula more readable.) To avoid typographical
errors, choose variable and function names from the Variable and
Function lists rather than typing them in.
Graph Column On
The newly calculated column can be graphed either on the y- or the xaxis. In this case the default of the y-axis is appropriate. The new
column will replace whatever had been graphed on its column.
Try New Column
When you click on the Try New Column button, the calculation will be
performed and plotted if some data have already been taken. If you like
what you see, click on OK to return to the main graph window which
will include the calculated plot.
Enter data manually

Æ

To enter a data column manually, choose New Column
Manual from
the Data menu. Enter a label, short label, and units in the fields
provided. Choose a color and point protector as desired.
The data table will contain a new, blank column. Click on a cell to type
in values.
To paste a column of numbers from the clipboard into a Manual Entry
column, click the first cell, then choose Paste from the Edit menu.
You must have already collected data from a sensor to enter data
manually. The maximum number of manually entered points is limited to
the number of points already collected from a sensor.

Copy data to a spreadsheet
or graphing program

To copy all or part of your data in numerical form, select the desired
portion of the data table; you can select it all by choosing Select All from
the Edit menu. Next, choose Copy from the Edit menu to place the data
on the clipboard. Now switch to the destination application.
Once you have the receiving spreadsheet ready to accept the data,
choose Paste from the Edit menu. The data will appear in the
application. You do not have to quit Logger Pro to switch to another
application.
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Save and Print Data
Save data, calibration and
configuration

You can save your experiment to disk by choosing Save from the File
menu. The experimental configuration, including data, calibrations,
column definitions and window types will be saved. A standard save file
dialog box will appear. Choose a location for the file, enter a descriptive
file name, and click on OK.
Saving a complete configuration in this manner is an excellent way to
record an experiment so you can later reproduce or extend the work in
identical conditions. In addition instructors can save a configuration for
students to use later; students then do not have to perform any
configuration or calibration and can immediately begin to collect data.
To save only the calibration information so that it is available when
manually configuring Logger Pro, open the Sensor Setup dialog box.
Then click on the input corresponding to the desired calibration and
click on the Save button. Enter a name for the calibration file of eight
characters or fewer, and click on OK. The file will be saved to the
default calibration folder set in Logger Pro Preferences.

Paste data into other
applications

Select the data and choose Copy from the Edit menu to place the data on
the clipboard. Paste the data into the receiving application, or to a text
editor to create a text format data file.

Retrieve an experiment

Choose Open from the File menu, and navigate to the folder containing
the desired file. Click on the file name. Since experiment configuration
is stored in a Logger Pro file, on loading the file any current
configuration will be overwritten.

Print a graph or data table

To print a graph or data table, make the graph or data table the active
window by clicking on it, choose Print Window from the File menu, and
respond to the resulting dialog box.

Print the screen

To print the entire Logger Pro screen, choose Print Screen from the File
menu.

Set default file locations

The default location of calibration and experiment files can be set in
Logger Pro preferences. While experiment files may be stored anywhere,
Logger Pro will first look in the default experiment file folder.
Calibration files, both those saved by users and those supplied with
Logger Pro, must be within the default calibration folder.

40

Logger Pro

Teacher’s Guide
To set default file locations choose Preferences from the File menu. You
will see this dialog box.

Click on the appropriate Browse button to change either the default
calibration or experiment file folder. Choose the desired folder in the
subsequent
dialog,
and
click
OK.
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Software Installation
Required materials

To use Logger Pro, you must have the following equipment:
A computer:
• A PC running Windows 95/98/2000/ME, Windows NT 4.0 with
at least 16MB RAM, and at least a 486 processor. Serial ports
must have a 16550 UART chip. If the computer’s mouse is
connected to a serial port, this means the computer will need
two serial ports. (Please contact us for further details.) Users of
LabPro with Windows 98/2000/ME may substitute a USB
connection for the serial connection.
or:
• A Power Macintosh or Power PC running System 7.6.1 or newer
with at least 16MB RAM, 10 MB of hard disk space, and an
unused modem, printer, or USB port.
An interface, which can be any of the following:
• A LabPro interface with a 6-volt power supply or batteries and
interface cable
• A Universal Lab Interface (ULI) with a 9-volt power supply and
an interface cable
• A Serial Box Interface with a 9-volt power supply and an
interface cable
At least one sensor:
• A temperature sensor or a Motion Detector are good choices for
initial testing of Logger Pro. The Voltage Probe included with
LabPro, the ULI, and Serial Box Interface can also be used.
All of these items (except computers) are available from Vernier
Software & Technology, 13979 S.W. Millikan Way, Beaverton, Oregon
97005-2886, (503) 277-2299, email: info@vernier.com, web site:
www.vernier.com.
Appendix C discusses the differences between the interfaces, and
Appendix D lists sensors compatible with Logger Pro.

Initial setup

Before turning on your computer, you should set up the interface with a
sensor. The interface should be placed near the computer. First connect
the interface cable to the interface. Then attach the cable to any unused
serial port3 or USB port as appropriate. For USB use we recommend
direct connection to the USB port without a hub.

3

On the PC, the connector on the computer may be either a 25-pin plug or a
smaller 9-pin connector. An adapter is supplied with the interface to make the
appropriate connection to your computer.
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to serial port

to Serial I/O

interface

to
power adapter

to 115VAC

Interface Connections
Next, plug the power supply into the matching receptacle on the
interface and into a source of 60-Hz, 115-VAC power.
Software installation
Macintosh

To install Logger Pro on a Power Macintosh, follow these steps:
• Place the Logger Pro CD in the CD-ROM drive of your computer.
• Double-click the icon Install Logger Pro and follow the instructions on
screen.

Software installation
Windows

To install Logger Pro on a computer running Windows 95/98/2000/NT
4.0, follow these steps:
• Place the Logger Pro CD in the CD-ROM drive of your computer.
• If you have Autorun enabled, the installation will launch automatically;
otherwise choose Settings
Control Panel from the Start menu.
Double click on Add/Remove Programs. Click on the Install button in
the resulting dialog box.

Æ

• The Logger Pro installer will launch, and a series of dialog boxes will
step you through the installation of the Logger Pro software. You will
be given the opportunity to either accept the default directory or enter a
different directory.
Software installation
Windows® 3.1x

Logger Pro 2.1 does not support Windows 3.1, however versions prior to
2.0 did. Contact us at info@vernier.com for detailed information.

Software installation
(network)

If your computers are served software from a central file server on a
network, you can install Logger Pro on the server.
Additional suggestions for configuring a network server to work with
Logger Pro can be found in Appendix B.
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Ideas for using Logger Pro in the classroom
How to use the tutorials

The tutorials, printed separately from this manual but included with
Logger Pro, can also be used as a student introduction to the program.
The first two, Temperature and Motion, are parallel introductions to
Logger Pro. The former is designed for all students, and the latter for
students who will use the Motion Detector. The remaining tutorials
extend the two introductory tutorials to more advanced use, including
data analysis and curve fitting. They might be used as individual class
assignments or could be made available for reference as students begin
using Logger Pro.

Experiment files are
important!

Experiment files contain information about the particular configuration
of Logger Pro, including the number of graphs, what is plotted on each
axis, the data collection rate and mode, what sensors are connected to
inputs, and the calibration information used. In other words, a complete
data collection environment can be saved for later use. If a custom
calibration is performed, that information is saved in the experiment file
without requiring a separate calibration file. Once an appropriate
experiment file is loaded and the interface and sensors connected, you
are ready to collect data.
Many teachers find that they spend less time teaching computing and
more time teaching science if they make use of experiment files. Some
curricular packages include experiment files for Logger Pro, so that
students can load an indicated file and be ready to take data in a mode
appropriate for the experiment. You can also create your own experiment
files for use with custom laboratory experiments. See the section below
on creating your own experiment files.

Experiment files included
with Logger Pro

Logger Pro comes with an extensive set of experiment files. The first set
is designed for typical experiments done with each Vernier sensor. These
files are in folders corresponding to the sensor name. The next set, found
in the Tutorials folder, is for the tutorials earlier in this manual. The
remaining sets are keyed to the specific experiments found in the Vernier
publications of ready-to-use classroom experiments and other available
publications.

Protecting experiment files

When experiment files are installed on individual computers, it is
important to keep the files from being unintentionally altered. The openfile dialog box includes a check box marked Open as Read Only. When
the check box is marked (the default), a file is opened as read-only. A
read-only file can be used normally, but it cannot be saved using the
Save command. The save button on the toolbar and the Save command
are disabled, and if the user clicks Save As…, the file name field is
blank. The file can be saved under any name, but if the name matches an
existing file an extra confirmation dialog will be presented.
If you intend to make permanent changes to an experiment file, clear the
check box, open the file, and make the desired changes. Save your file.

Sources of experiments for
Logger Pro
from Vernier

• Biology with Computers, by David Masterman, and Scott Holman 30
experiments.
• Chemistry with Computers, by Dan D. Holmquist and Donald L. Volz,
30 experiments.
• Middle School Science with Computers, by Donald L. Volz and Sandy
Sapatka, 37 experiments.
• Nuclear Radiation with Computers, by John Gastineau, 6 experiments.
Logger Pro
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• Physical Science with Computers, by Donald L. Volz and Sandy
Sapatka, 41 experiments.
• Physics with Computers, by Kenneth Appel, John Gastineau, Clarence
Bakken, David Vernier, Richard Sorensen, 34 experiments.
• Water Quality with Computers, by Robyn L. Johnson, Scott Holman,
and Dan D. Holmquist, 16 tests.
• Interactive Lecture Demonstrations, by Ronald Thornton and David
Sokoloff, demonstrations in motion, force and energy.
• RealTime Physics, by David Sokoloff, Ronald Thornton and Priscilla
Laws, 12 experiments in mechanics.
• Tools for Scientific Thinking, by Ronald Thornton and David Sokoloff.
Experiments in Motion and Force; Heat and Temperature, Sound.
For convenience the folders of experiment files for the first seven
books have been moved to the beginning of the folder.

Calibration files

Although creating an experiment file will save calibration information,
you can also save sensor calibration information separately. Your custom
calibration will then be among those offered in the sensor setup dialog.
Logger Pro includes calibration files for the Vernier sensors listed in
Appendix C. For most sensors these calibrations are all you will need. A
few sensors, such as for dissolved oxygen and colorimetry, need
individual calibration; the force and pH sensors can be calibrated for
higher-accuracy results. The calibration procedure is described in the
reference section.

Creating an experiment file

To create your own experiment files, you will need to set up Logger Pro
as appropriate for your experiment. You may want to start with an
existing experiment file that is close to the configuration you need.

y Configure or confirm that Logger Pro is properly set for the sensors
you will use, including any calibration information.
y Set the data collection mode, period, and rate as needed.
y Define any new columns you need.
y Set up the graphs as desired. Create the number of graphs, the
scaling, and what is plotted for your experiment.
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y Consider entering an Experiment Note (choose About filename from
the Help menu, where filename is the experiment file name) to give
preliminary instructions that will be displayed when the file is first
opened.

y Consider adding an explanatory or instructional text window that will
be visible during data collection. (Choose New Window Æ Text)
y Test your setup by performing a trial experiment, and make changes
as needed.
y If you do not want to save your example data with the experiment
setup, clear the data by choosing Clear All Data from the Data menu.
y Choose Save from the File menu. Enter a descriptive file name, and
save the file.

To use the file later with students, place a copy of the file in the default
experiment file directory specified in the Logger Pro preferences.
Customizing Logger Pro

Certain settings of Logger Pro, such as the default location of files
which you are unlikely to change every session, can be stored in
preferences. See Preferences under the File menu. Preferences are stored
locally on the computer. Consult Appendix B for detailed network
suggestions.

Using Logger Pro on a
network

Using Logger Pro on a network is similar to using it on a stand-alone
computer. However, the benefits of network access to Logger Pro
include the need to install only one copy of the software, further
protection of experiment and calibration files from accidental change,
and reduced hard disk requirements on the local computers. For details,
see the discussion in Appendix A.

Using Logger Pro on
stand-alone computers

During the installation process above, a directory will be placed on your
hard disk which includes Vernier calibration files and experiment files.
Preferences will initially be set to these directories as default.

Sensors for Logger Pro

Appendix C lists the sensors compatible with Logger Pro.

Customizing auto-ID
functions (LabPro only)

LabPro and Logger Pro work together during the auto-ID operation.
LabPro reports the sensor type to Logger Pro, which then opens an
appropriate experiment file from the VSautoID folder. As a result it is
easy to change what happens when an auto-ID sensor is detected. Set up
Logger Pro in the desired mode, and replace the appropriate experiment
file in the VSautoID folder. You can determine which experiment file is
used by a sensor by selecting About LabPro from the Help menu.

Logger Pro
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Keystroke Equivalents
Logger Pro supports standard keystroke equivalents for common menu
commands. On PC hold down the Control key (it may be labeled Ctrl on
your keyboard) and the appropriate letter key. On Macintosh computers
hold down the Command key while striking the appropriate letter key.
command

keystroke

Collect/Stop

Enter

New

Control/Command N

Save

Control/Command S

Open

Control/Command O

Print Screen

Control/Command P

Strikethrough Rows

Control/Command K

Zero

Control/Command 0

Autoscale Once

Control/Command U

Store Latest Run

Control/Command L

Replay

Control/Command R

Integrate

Control/Command I

Copy

Control/Command C

Cut

Control/Command X

Paste

Control/Command V

Adjust Data Collection

Control/Command D

Adjust Sampling

Control/Command M

Adjust Triggering

Control/Command T

Examine

Control/Command E

Toolbar

The toolbar provides quick access to some common functions. From left
to right, these are Open, Save, and Print Screen. The next group includes
Autoscale Once, Zoom In, Zoom Out, and Undo Zoom. The third group
toggles Analyze, Tangent, Statistics, Integral, Line Fit, and Automatic
Curve Fit. Next, the stopwatch button opens the data collection dialog
box. The icon showing an interface selects the Sensor Setup dialog, and
Logger Pro
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the Collect button initiates data collection. If present, the Zero button
resets an analog sensor reading to zero.
You can quickly see what a tool does by positioning the pointer over the
button for a moment; a legend will appear.

Cursor Controls
You can change the graph appearance and behavior through a number of
“hot spots” on the Graph Window and the Table Window. The screen
below shows some of these functions.

Graph Window

50

These areas of the Graph Window are active to cursor control:

Graph title

Click on the graph title to obtain a dialog box in which you can modify
or remove the graph title.

Tick mark labels

You can click on the minimum or maximum axis numeric labels and
type in a new value. The axis of the graph will change accordingly.
When the independent variable is time, the right-most time value will
also determine how long data are collected except when the graph has
been turned into a strip chart.

Axis labels

Clicking an axis label will open a dialog box that allows you to choose
what is plotted on that axis.

Scroll arrows

You can scroll the viewing region of the graph with the scroll arrows.
The axis limits will change, but the interval displayed by each axis will
remain the same.

Axes

To change the scale of one axis at a time, click on the area between the
axis and the axis label. A dialog box will open, allowing you to control
the scaling of that axis.
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Graph options

Double-click on a graph to change several properties at once. The Graph
Options dialog will appear; allowing you to change scaling, labels, or
plot style. More details can be found under Graph Options in the Logger
Pro Menus section.

Selecting a graph

If there is more than one graph window on the screen, most commands
that affect graphs will change only the selected graph window. To select
a graph, click on it. A border will appear around the graph to indicate
that it is selected.

Table Window

The Table Window also responds to clicks:

Select All/None

Clicking the All/None button will alternately select all data and no data.

Column properties

Double-clicking the row numbers will open the Table Options dialog.
There you can change the font used and choose which columns will be
displayed.

Column options

Double clicking the Run Heading (Latest, Run 1, and so forth) will open
a dialog box holding a list of columns. Select a column, click on OK,
and the Column Options dialog for the chosen column will open.
Double-clicking a specific column header will open its Column Options
dialog directly. You can find more details about Column Options under
the Data menu details below.

Column order

To rearrange the order of displayed columns, drag the column header to
the desired position.

Edit cell contents

Only cells in manually entered columns or prompted columns collected
in Events with Entry mode can be edited. Click the cell to be changed.
Type in the new value, and press enter.

Strikethrough Rows

To ignore sensor-collected data (which is not editable), select the data
range in the table and choose Strikethrough Rows from the Edit menu.
Selecting Strikethrough data in the table and choosing Restore Rows
from the Edit menu restores this data.

Logger Pro

51

Logger Pro Reference

Logger Pro Menus
Apple menu
About Logger Pro…

(Macintosh only)
Choose this item to display information about Logger Pro. The version
number and copyright notice are displayed.

File menu

New

Choose New to open the startup window and data table. All prior data,
configuration, and calibration information will be lost. If a LabPro
interface is connected and an auto-ID compatible sensor is connected to
the LabPro, Logger Pro will attempt to open an appropriate experiment
file automatically.

Open

Choose Open to open a previously stored experiment file. In addition to
standard open-file dialog features, there is a check box which when
filled will cause files to be opened as read-only. A read-only file can be
used for data collection, but if the user clicks or chooses Save an error
message will be displayed, protecting the original file. A read-only file
can be saved under a new file name using Save As…. The default is to
open files as read-only.

Close

Close closes the current experiment without quitting Logger Pro.

Save

Save will record the current experiment to disk. If the experiment has
not been saved before, Save is equivalent to Save As. If the experiment
has been previously saved, the experiment file is updated.

Save As…

This will save the current experiment setup including calibrations and
any data in the data table. Opening this file later will restore Logger Pro
to its current setup.

Import Data

Use this feature to import data saved with the Export Data option also
found in the File menu. These data exist in a tab-delimited text format,
and are imported into the Latest data run. Each file has a specific
structure that includes a time stamp, data column names, short names,
units, and data. If you make changes to the exported file, be sure to
preserve the original structure. After choosing this option, select the
appropriate file. If you plan to collect data after importing, you may need
to configure the sensors before importing data. (See How To Configure
Sensor Functions in this manual.)
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Export Data

This option exports data to a tab-delimited text file. Only raw data
including time and manually entered data from the data run you select
are exported to the file. Calculated columns or curve fit columns are not
saved. A time stamp, column names, short names, and units are saved to
the beginning of the file. After choosing this option, enter the name of
the file you wish to create. Note: Do not confuse this option with the
Save or Save As options which save all the details of the current
experiment. Use the Export Data option only if you want to create a file
that can be read by other applications such as spreadsheets or word
processors. You can instead use copy and paste features to transfer data
to other applications.

Printing Options

Printing Options calls a dialog box in which you can set text that will be
printed with any graph or data table. This helps to identify printouts
coming from a shared printer. If the Date field is checked, the date and
time of printing are included on the page. If the Always Show Page
Setup field is checked, this dialog box will be displayed whenever the
print command is issued. In that case, clicking OK will then display the
Print dialog box where the number of copies is set.

Clicking on the Page Setup button will display the current printer’s
setup dialog. Options such as print quality and paper source can be
chosen here. The same dialog may be accessed with the next menu item,
Page Setup.
Page Setup

Page Setup accesses your printer’s Print Setup dialog where you may see
which printer is to be used, change the printer’s properties, and the paper
size and print orientation.

Print Window

Choose Print Window to print either a graph or data table window,
whichever window type is active. If the active window is a graph
window with more than one pane, you will be given a choice of printing
one pane or all panes. The available options will depend on the type of
printer available.

Print Preview

Print Preview will show a reduced-size image of the page as it will be
printed. This is useful to ensure that a given print request won’t take too
many pages.

Print Screen

Print Screen prints the entire Logger Pro main window with all of the
window types currently displayed as they look on your screen.
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Preferences

There are three classes of Logger Pro settings under user control: default
file locations, graph behavior, and hardware.
The default locations of calibration information and experiment files can
be set using the Folder Locations tab.

Logger Pro will only detect calibration files stored in the default
calibration folder. New calibration files are saved to this folder as well,
and will subsequently be available in the list of calibrations in the
Sensor Setup dialog box.
In contrast, experiment files may be stored anywhere, but Logger Pro
will first look in the default location set here.
To set either folder location, click the appropriate Browse button and
navigate to the desired folder, or just type in the full path to the desired
folder.
Preferences are stored for the use of Logger Pro and are not saved with
experiment files.
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The Graph behavior preferences tab allows you to set graphing options.
If Over Range Autoscale is checked, Logger Pro will automatically
rescale the graph vertically during data acquisition to include any data
point acquired even if it may exceed the existing range settings of the
graph.
Graph behavior preferences allow graph drawing and text to be
emphasized for overhead projection.

The Hardware tab allows you to determine to which interface Logger
Pro defaults when no real interface is attached. This allows experiment
setup without a physical interface attached to the computer. Most Recent
is the last interface to which Logger Pro connected on this computer.
Quit (Macintosh) or Exit (PC)

Choosing Quit or Exit causes Logger Pro to prompt you to save any
unsaved data, then exits the program.
Logger Pro
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Edit menu

Undo

The Undo command will reverse the effect of the most recent operation
(if possible). For example, after data collection, the Undo command
becomes Undo Collect. This is valuable if the previous run is needed but
had not been stored.

Cut

Cut removes the selected data and places it on the clipboard. Not all data
may be removed. Measurements made by Logger Pro directly (the raw
data) are locked and cannot be deleted. New columns that you create are
unlocked and can be edited or cleared.
The locking of raw data columns is an intentional feature of Logger Pro.
Since the raw data are simply a record of what is measured by the
sensor, it is inappropriate to change them, much as a scientist never
erases data from a notebook.

Copy

When a graph window is the active window, Copy will place a copy of
the graph on the clipboard. When a table window is the active window,
Copy will copy the data to the clipboard. You can then paste from the
clipboard into another application.

Paste

Paste places a copy of the clipboard contents at the cursor location.
Pasting is possible in the text window and into Manual Entry data
columns.

Clear

Clear removes the selected data without putting them on the clipboard.
Locked data such as original data may not be removed. Only manually
entered data may be cleared.

Select All

Select All is used to select the entire data table for subsequent copying.

Strikethrough Rows

Strikethrough Rows disables all selected rows (those points won't be
drawn or used in any way). It displays each selected row in the data table
with a line drawn through it.

Restore Rows

Restore Rows reverses the Strikethrough action for the selected rows.
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Experiment menu

Collect

Collect begins a data collection run. Clicking the Collect button in the
toolbar or pressing the Enter key has the same effect.

Replay

After data are collected, choose this item to get an instant replay of the
data collection. Select the run you wish to replay from the drop-down
menu. You can set the replay rate to faster than real time, slower, or to
the original rate.

Stop

Stop causes data collection or replay to cease.

Sampling

Sampling opens the Sampling tab of the Setup Data Collection dialog
box. For additional information see the discussion under Setup menu.

Triggering

Triggering opens the Triggering tab of the Setup Data Collection dialog
box. For additional information see the discussion under Setup menu.

Live Readouts

This is a toggled mode. Choose Live Readouts to turn the mode on (a
checkmark appears next to the menu item); choose it again to turn off.
When the Live Readouts mode is on, the current sensor readings will be
displayed in any meter window. When Live Readouts is disabled, the
meter window reports the sensor value on the graph nearest the cursor
position. The current sensor readings are always displayed in the status
bar.

Options

Logger Pro uses a range of points to calculate derivatives, tangent line
slopes, and smoothed data. You can set the number of points used for
these functions. The first setting affects the derivative( ) functions used
in column definitions as well as the drawing of tangent lines. The
Logger Pro
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second setting affects only the smooth( ) functions used in column
definitions.
In either case, a smaller number of points will make the functions more
responsive to small changes in the data, but larger numbers will reduce
noise.

If the Display zero button item is checked, a Zero button will be placed
on the toolbar. The zero button will tare (zero) the reading of applicable
analog sensors such as the Force Probe.
The Enable Automatic Curve Fit option is checked by default.
Unchecking it will disable the Automatic Curve Fit function from the
Analyze menu and the Toolbar. Users may wish to disable automatic
curve fits to force students to perform manual curve fits instead.
The choice of angular units used in trigonometric calculations in Logger
Pro is selected by clicking either Radians or Degrees.
All settings in the Options dialog are stored with an experiment file.
Calibrate

Calibrate is a shortcut to the Calibrate tab of the Sensor Properties
dialog. The sensor setup discussion below gives step-by-step
instructions for performing a calibration.

Zero

Zero resets a sensor to zero without
otherwise changing its calibration. Zero
is primarily used with force sensors, but
can be used with any analog sensor, as
well as the Motion Detector and the
Rotary Motion Sensor. If two or more
sensors are active, the following dialog
box is presented, allowing you to choose
which sensor(s) are to be zeroed.
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Data menu

Store Latest Run

Show Run

Hide Run

Æ

Æ

Æ
Delete Run Æ
About Run Æ
Rename Run

To preserve a run in memory choose Store Latest Run. If you do not
store it, the next time the Collect button is clicked the latest run will be
deleted automatically. Stored runs are numbered sequentially as Run 1,
Run 2, and so forth. You can store as many runs as your computer’s
memory allows.
Show Run is a hierarchical menu, which allows you to select which runs
will be shown on the graphs and data tables. The number of choices
depends on how many runs you have stored.
Hide Run is also a hierarchical menu. It allows you to keep a run from
being plotted or shown in the data table. You can choose between the
latest run and any stored runs.
Rename Run gives you the option of giving each data collection run a
meaningful name.
Delete Run allows you to remove any stored run from memory, as well
as the latest run.
Choosing a run from the
hierarchical menu of About Run
shows the time the data
collection began. A text area
allows you to enter notes about a
run. This information is only
available by again choosing
About Run.
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Sort Data will arrange rows in
the data table according to
values of the selected column.
This function is useful if data
were gathered in another order,
and now you want to integrate
or plot the data with connecting
lines.

Sort Data

On selecting Sort, you will see
a dialog where you can choose
the column that will determine
the sort order, and whether the
sort is ascending or descending.
Once you have sorted a data
column, the sort will be
performed on all subsequent runs as the data are collected.
This command allows you to define a new column of data that will
appear in the data table and optionally on the graph. The new column
may be either a column calculated from other columns using a formula,
or it may be manually entered. For both types of new columns a tabbed
dialog box appears. The new column must be named and may be given
units.

New Column

New Column
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Æ Formula

After setting the new column name and units, formula-based new
columns require a defining formula. The definition tab allows you to
define new columns based on other columns using an equation. To
create a new column based on an equation, enter the desired relationship
in the equation field. The contents of existing columns can be chosen
from the Variables menu, and common mathematical functions can be
chosen from the Function list. For more information see the tutorial on
creating new columns.
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The functions include several appropriate to columns of data:
integral
The integral function gives the running sum of the product of point
values and the increment of the independent variable, which is usually
time. That is, it delivers the numerical integral of the data column.
trigonometric
Trigonometric functions like sine, cosine, and tangent are included.
smooth
The smooth function reduces noise in the indicated column. The number
of points used for a moving average is controlled in Options found under
the Experiment menu.
initial
The initial function inserts the value of the first row of data and for all
rows of data. This can be used to create an automatic offset so that a
column of data is relative to its starting value. For example, "Dist" Initial ("Dist") will generate a column of data where position is relative to
the starting position instead of absolute.
sum
The sum function adds the values for all rows up to and including the
current row.
Graph Column On
The calculated column can be graphed on either axis. The default choice
is the y axis. Click the x-axis label to plot the new column on the
horizontal axis.
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Try New Column

New Column

Æ Manual

Clicking the Try New Column button will graph the new column in the
sample graph. You can make changes to the definition, and check out the
changes by clicking this button again. Click OK to keep the new column
and return to the main Logger Pro screen. Cancel will close the dialog
box and discard any entries.
Manual columns only require a name. The new column will be created
in the data table. Select a cell by clicking it. Type in your values, ending
each entry with the enter or return key. You can also paste a column of
data after clicking the first cell. Manual columns are limited to the
number of data points already collected using a sensor.

Modify Column

Modify Column allows you to change the definition of a calculated
column. The same dialog box as for New Column above is displayed.

Delete Column

Use Delete Column to remove unneeded columns.

Column Options

Column Options opens a dialog in which you can change the name of
the column, change the point style used, units, and displayed precision
of data. Use this option to modify existing columns.

Clear All Data

Clear All Data removes all data from the data table. You will be
prompted to save any unsaved data.

Analyze menu

Examine
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Examine is a toggled mode (a checkmark appears next to the menu item
when it is on). When active, the mouse pointer becomes a vertical line
and the value of the data at the indicated time is displayed in the graph
legend.
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Tangent

Tangent is a toggled mode (a checkmark appears next to the menu item
when it is on). Tangent enables the drawing of a short tangent line at the
cursor location to each data column plotted. The numerical value is
displayed in a floating box. The number of points used to calculate the
slope can be set in under Preferences in the File menu.

Make Annotation

Make Annotation allows you to create a floating box with any text you
choose. This is useful for placing comments on graphs. To edit an
annotation, double click on the floating box. To remove an annotation,
click the close box on the upper right corner of the floating box.

Interpolate

The interpolate function can only be used after a function has been fit to
experimental data using the Automatic Curve Fit…, Manual Curve
Fit…, or Linear Fit function described below. After choosing interpolate,
the value of the fitted function is displayed as a function of cursor
position.

Linear Fit

Linear fit performs a linear least-squares fit on the selected data. If there
is no selection made the entire data run is used.

Automatic Curve Fit

The Automatic Curve Fit item gives you a choice of advanced curvefitting options. These curve fits are automatic in the sense that the fit
parameters are determined by Logger Pro using the least-squares
methods. The dialog box below is opened.

The graph portion of this window gives you a preview of the fit and
allows the selection region to be modified. To perform a curve fit,
choose first the type of fit from the scrolling list at lower left. For the
case of the polynomial fit, enter the degree of the polynomial in the
Degree field. Next, choose the column to be approximated by the fitted
equation. Click on Try Fit to see the result. Modify your choices as
desired. You can modify your data selection by repeating a drag across a
portion of the data and clicking on Try Fit again. Once you like the fit,
Click on OK to place the fit on the main graph window, or Cancel to
discard the fit altogether.

Logger Pro

63

Logger Pro Reference
Clicking Create Column will place a new column in the data table
containing the value of the fitted equation at each time.
The Curve Fit Options tab holds a new dialog box.

The Curve Fit Options tab allows you to determine which fit statistics
are displayed on the graph. The Equation’s Coefficients are the fitted
parameters. The Mean Square Error and its square root, the Root Mean
Square Error, measure how far away on average the fitted function is
from the data. The Root Mean Square Error is in the units of the data on
the y-axis.
You can also specify the style and color of the line representing the fit.
The Sample Line region provides a preview of the line appearance.
The Displayed Precision field allows you to set the number of displayed
digits in the curve fit floating boxes. Select one of Decimal Places (a
fixed number of places past the decimal point) or Significant Figures
(the number of digits displayed, plus any need to show magnitude).
Enter the desired numerical setting for either mode.
For the linear fit only, the fit and its statistics are determined as follows.
We have N ordered pairs of xi and yi. The best fitting line y = ax + b is
then given by

(

1
∑ xi2 ∑ yi − ∑ xi ∑ xi yi
∆
1
b=
N ∑ x i yi − ∑ x i ∑ y i
∆
a=

(

where ∆ = N ∑ xi2 − (∑ xi )

)

)

2

Measures of the goodness of fit are many. Most common are the scatter
standard deviation, σs, the linear correlation coefficient r, and the
uncertainties of the parameters a and b, σa and σb. The scatter standard
deviation measures how far away, on average, the data points yi fall from
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the fitted line, measured along a vertical line.4 σs is also called the root
mean square error, and is defined as
σs =

(

1
∑ yi − a − bxi
N −2

)2 .

We use N - 2 weighting since two parameters have been determined in
the curve fit.
The remaining quantities are defined as
σa =

σ s2
∆

σb =

N

r=

∑ xi2

σ s2
∆

N x2 −
 ∑ i

N ∑ xi yi − ∑ xi ∑ yi

(∑ xi )2 

1/ 2

N y2 −
 ∑ i

(∑ yi )2 

1/ 2

The first two quantities are interpreted as the variance of the fitted
parameters, and so can be used as 67% confidence level uncertainties of
the slope and intercept.
The correlation coefficient, r, is commonly calculated by scientific
calculators, but is a difficult quantity to interpret. The correlation
coefficient is intended to measure the degree of correlation between the
x and y values. It is not directly a measure of goodness of fit. For no
correlation at all (random values), r is near zero. For perfect correlation r
is ±1. From r one can determine a probability that the x and y values are
correlated. In the natural sciences, however, there is usually the
assumption that the two are correlated, and so the r value is not very
useful. Far more useful to a student or scientist is the uncertainty of the
slope and intercept. These uncertainties answer the question “How well
did the data determine a slope (or intercept)?”.
No provision has been given to weighted fits, since in computeracquired data all data points are generally equally reliable.
More information on curve fitting and the interpretation of the fitted
parameters can be found in Data Reduction and Error Analysis for the
Physical Science, 2nd edition, Philip R. Bevington and D. Keith
Robinson, McGraw-Hill, Inc., 1992.
The automatic curve fit function can be disabled in the Options, found in
the Experiments menu.
Manual Curve Fit

Logger Pro will superimpose a function (sometimes called a model) over
your data using the Manual Curve Fit option. In contrast to the automatic
curve fit discussed above, where the parameters in the fit equations are
determined automatically using a least-squares technique, the Manual
Curve Fit allows you to adjust the parameters by hand.
A manual fit is often appropriate for instructional purposes. By adjusting
parameters manually, students will learn how each affects the fit. A
manual fit will also allow you to adjust a curve to fit a data series in the
way you want, possibly ignoring certain stray points within the series.
To perform a manual fit, click once on a graph to make it active.
Optionally, select a region of the graph using the mouse. This selection
region is used only for calculating the mean square error of the fitted
4

The least squares fitting method assumes that the uncertainties in the x values
are negligible compared to the uncertainties of y.
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function with respect to the data. If you do not plan on using the mean
square error value, then it is not necessary to select a region. Then, select
Manual Curve Fit from the Analyze menu. A new dialog box will open.

First, you must select or enter an equation. The faster method is to select
an equation from the General Equation menu. In the screen shown
above, the linear relation y = mx + b has been selected. You can also
enter your own relationship in the Equation field. The equation must
contain between one and five adjustable parameters (single upper- or
lower-case letters) and the horizontal axis variable is entered as x.
The values of each parameter may be adjusted in the Parameters fields.
You can either type in a new value directly, or you may use the up and
down arrows to increase or decrease the values using the mouse. Click,
or click and hold, on the desired arrow.
The ∆ button near each parameter allows you to set the adjustment
increment applied when the arrows are used. The ∆ button for the b
parameter has just been clicked in the screen above. If the Auto Delta
box is checked (default is unchecked) then the increment will be made
smaller when the parameter reaches a magnitude similar to the
increment.
Using the manual fit can be very helpful in understanding fitted
functions, but it can also be frustrating. A random or poorly chosen set
of parameter values may result in a function that does not cross the
graphed region at all. Blind adjustment of the parameters will not often
move the function into view. Once a part of the function is in view, it is
usually easy to adjust the parameters to get a good fit.
If your graph starts at x = 0, one way to get the function into view at the
start is to adjust the y-intercept value to match that of your data. Then
you will see at least a portion of the function, allowing you to adjust
other parameters as needed.
Clicking Create Column will place a new column in the data table
containing the value of the fitted equation at each x-axis value.
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The Perform Fit On menu allows you to select the column used for
calculating the Mean Square Error value. The Mean Square Error
measures how far away the function is, on average, from the data.
Automatic curve fits seek to minimize this value.
Integral

Integral performs a numerical integration on the selected data.
First drag across the desired region of your data to select. Then
choose Integral (or click on the Integral button on the toolbar). You will
have the opportunity to specify which data set you want to integrate. The
numerical result is shown on the graph, and the corresponding area
shaded.

Statistics

The Statistics item displays a dialog showing statistical measures
of the selected data: maximum, minimum, mean, standard
deviation, and the number of points used. You may optionally select a
region of the data first. The entire data set is used when no selection is
made. After you select Statistics (or click on the Statistics button on the
toolbar) you will have the opportunity to specify for which data set you
want statistics calculated. The statistics are presented in a floating box
on the graph screen.
The standard deviation is found using N-1 weighting, or
σ=

(

1
∑ xi − x
N −1

)2 .

View menu

The first item in the View menu changes depending on the active
window. For example, to see Data Table Options, click once on a data
table before pulling down the View menu. Options settings for Text,
FFT, and Meter windows are also available.
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Graph Options

Choosing this item is equivalent to double clicking the graph. The Graph
Features tab of the dialog box is shown first:

Point Protector Every … Points
If this item is selected, a marker will encircle one of every N points.
Marker color and shape can be chosen by Choosing Column Options
from the Data menu.
Legend
Selecting Legend causes a legend to appear on the graph. The Legend
identifies the plotted columns by color and line style. A Legend appears
automatically when in Examine mode.
Connecting Line
Enabling Connecting Line draws a straight line from one data point to
the next.
Bar Graph
If this option is selected Logger Pro will draw vertical bars from the
horizontal axis to each data point. The bar width in pixels can be set in
the width field.
3D
If this option is selected, Logger Pro will draw the vertical bars of a bar
graph with shadows, giving an illusion of depth.
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Grid
A gridline for every tick mark can be displayed if desired. The color and
weight of the lines are controlled using the two pop-up menus at the
bottom of the dialog box.
Graph Title
A graph title can be displayed if desired. The text of the graph title can
be entered in the Graph Title field.
The Graph Options dialog also has an Axis Options tab:

Here you can control what is plotted on the two axes as well as the
scaling used. The settings here are duplicated in the axis scale and
selection dialogs obtained by double-clicking an axis or axis label. The
columns shown will depend on your specific configuration of Logger
Pro. Scaling choices will also be used in subsequently collected data.
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FFT Options

FFT Options allows you to control the way the Fast Fourier transform is
calculated and the way the graph is drawn. The Graph Features tab
allows you to set the same features found on the Graph Options dialog,
describe just above.
The FFT tab determines how the FFT is calculated:

Choose Column(s) to Analyze:
The columns available will depend on the columns currently in the data
table.
Filtering
A raw FFT often will have undesirable artifacts, which can be reduced
by appropriate filtering.
Windowing reduces the weighting given to the first and last 10% of the
data sequence. This reduces high frequency artifacts due to the abrupt
beginning and end of data.
Turning on High Pass Filtering will ignore any constant or linearly
dependent component to the data.
Smoothing will reduce noise in the final FFT by performing a running
average on the raw data before the FFT is calculated.
Enabling Show Peak Frequency will display the highest amplitude
frequency.
Scale
Set the desired scale of the FFT frequency (horizontal) and amplitude
(vertical) axes.
Histogram Options

70

The Histogram Options dialog box controls the appearance of a
histogram. The Graph Features tab is a subset of the standard Graph
Features tab, while the Axis Options tab allows control of the histogram
bin width. The data to be displayed and the scaling of the x- and y-axes
is set as before.
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Data Table Options

Data Table Options lets you control the font, size, and presentation of
data columns through two tabbed dialog boxes. The first sets the font,
weight and size of the numerals:

Choosing Black and White in Table will disable the use of color coding
of the columns, which may make reading values somewhat easier.
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The Table Layout tab controls what columns are shown in the table. You
may want to hide some columns for clarity. The first option shows all
data. The second allows you to show just one selected run, and the third
lets you display one selected column across all runs. You can also hide
individual columns in the Column Options dialog box.

Meter Window Options

The data columns displayed in the meter window can be set by the user
in this dialog box.

Meter Layout

In addition you can control the layout and font size of meter window
readouts.
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The three grid layout options determine whether the meters are laid out
to fill the available space with the largest possible meters (Automatic), to
arrange data from each run vertically (By Column) or horizontally (By
Run).
The type size used in meters can either be set by the user or determined
automatically.
Graph Layout

Graph Layout allows you to control the way multiple graph panes are
shown in the graph window. Choose the desired option and click on OK.

There are two ways to display multiple graphs in Logger Pro; one is to
use two or more graph windows, and another is to use the Graph Layout
command to display two or more graph panes within a single window.
Graphs in separate windows are independent of one another, although
both depend on the same data table. Graph panes in a single window
share certain adjustments for ease of viewing. These shared parameters
are:
•

Changing the x-axis limits in one pane will automatically change the
limits in other panes.

•

Scrolling the x-axis plotting range using the scroll arrows will scroll
all panes.

•

Zooming into a selected region will zoom the horizontal axis of all
panes in the same manner.

•

Turning on the Examine tool shows the data points for all panes.

These connected adjustments will keep the horizontal axes synchronized
to allow easy comparison of each series. If you want independent
adjustment of the horizontal axes, use separate graph windows.
Zoom In

To zoom in on a portion of a graph, first draw a rectangle on the graph
screen by dragging the mouse across the desired area as you see here.
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Then choose Zoom In from the View menu, or click on the Zoom
In button on the toolbar. The graph will rescale, expanding the
selected region to fill the plotting area. If the Zoom In command is used
on one of several graph panes in a single graph window, the horizontal
axis will be changed in all graph panes.
Undo Zoom

Choosing Undo Zoom will reverse the last zoom action
performed, whether by the above Zoom In command or the
following Zoom Out command. You can undo multiple zooms with
multiple Undo Zooms.

Zoom Out

The Zoom Out command will double the range of both the x- and
y-axes.

Autoscale Once

Autoscale Once will change the scales so that the plotted curves
fill the graph area. The scaling only takes place for the current
range of data plotted. You can also click on the Autoscale Once button
on the toolbar.

Set Axes to Autoscale

Set Axes to Autoscale makes the automatic scaling of the currently
active graph permanent so that the graph scales itself automatically for
the current data and each subsequent range of data that is plotted. Both x
and y axes may be changed. The y axis will not necessarily include the
origin, so you may want to perform a more limited autoscale by clicking
the y axis and choosing Autoscale from Zero in the ensuing dialog.

Setup menu

Sensors

Use the Sensors menu item to set up Logger Pro to work with various
sensors.5
You will see this dialog box with three tabs. The basic sensor setup is
explained below. The Calibrate and Details tabs are described in turn.
5

The ULI inputs can be used in combination subject to these limitations:
Port 1 cannot be used simultaneously with DG1 or DIN1.
Port 2 cannot be used simultaneously with DG2 or DIN2.
DIN3 and DIN4 cannot be used simultaneously with a Motion Detector
DIN3 and DIN4 cannot be used at sampling rates over 50Hz.
For the original ULI and ULIII (revision 1.00) the ULI Force Probe must
be used in Port 1 and the Motion Detector must be used in Port 2.
The LabPro inputs can be used in combination subject to these limitations:
An analog sensor cannot be used at the same time as a photogate.
Two Rotary Motion Sensors cannot be used at the same time.
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Sensor Setup tab

To configure Logger Pro for a particular sensor,

y Click on the input to which you attached the sensor. For example,
CH1, DIG/SONIC2, and so forth.
y Choose the sensor name from the Sensor scrolling list. To turn off an
input, choose None from the top of the scrolling list.
y Choose the desired calibration file from the Calibration scrolling list.
Some sensors have several possible ranges or units choices. In most
cases you will use the default calibration.

If you do not need to perform a new calibration, click on the OK button
to complete the sensor setup.
Calibrate tab
Analog sensors can be calibrated to report measurements in physical
units either by manual calibration, from a stored calibration file, or by
manually entering slope and intercept information (Details tab).
Choosing Calibrate opens a dialog box allowing you to select a stored
calibration file or perform a new calibration. A new calibration requires
two independent measurements of the quantity for comparison to the
raw data readings. For example, to calibrate a temperature sensor you
must have two different water baths of known temperature.
To perform a new calibration,

y Choose Sensors from the Setup menu if the Sensor Setup window is
not already open.
y Click on the Calibrate tab at the top of the resulting dialog box.
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y Click on the input for the sensor you want to calibrate.
If you have several sensors of the same kind you can select multiple
inputs to calibrate the sensors at the same time.
First calibration point

y Click on Perform Now.
y Allow the sensor and the thermometer to stabilize at the first calibration temperature. You can determine this by waiting until the
displayed voltage values stop changing.

Second calibration point

Save calibration

y Enter the thermometer’s actual reading (in degrees) in the Value 1
field.
y Click on Keep.
y Move the sensor and thermometer to the second water bath.
y Allow the sensor and the thermometer to stabilize at the second
calibration temperature.
y Enter the thermometer’s actual reading in the Value 2 field.
y Click on Keep.

Calibration information is automatically saved when you save an
experiment file. As a result, it is not necessary to separately save a
calibration result unless you want the calibration to show up in the
scrolling list in the Setup Sensors tab. To make a calibration available in
the scrolling list,

y Click on Save to record the calibration in a separate file.
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You will see this dialog box.
Enter a name for the calibration file
in the first region. The scrolling list
shows all the available calibration
files. Optionally you may enter your
initials in the Calibrated by field.
Click on OK to save the file to the
default calibration folder as
specified in Logger Pro Preferences.
You will be warned before replacing
an existing file of your own;
Vernier-supplied calibration files
may not be replaced.
Details tab
Additional calibration information can be set on the Details tab of the
Sensor Setup dialog:

The calibration procedure creates a correspondence between the sensor
voltage output and the measured quantity (such as temperature) which
can be characterized by a slope and intercept. If someone has done an
earlier calibration of a sensor you can manually enter the calibration here
after clicking on the Unlock button. The Labels and Units can also be
changed. For example, this is where you could enter the calibration
parameters for a new sensor that does not have a supplied calibration
file.
Special note for Force Sensor
and Motion Detector

Force sensors and Motion Detectors show a special button, Reverse
Direction, which automatically changes the calibration to reverse the
sign of the force or distance data.

Special note for Rotary
Motion Sensor

The Rotary Motion Sensor is different from other sensors in that it has
modes of operation that can be controlled in software. These modes are
set in the Details tab of the Sensor Properties dialog box.
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Counts
This field contains the number of counts a particular sensor generates for
each revolution. The Vernier/PASCO sensors generate 360 counts for
each revolution, while others may be different.
Zero@Start
The Rotary Motion Sensor can be set to zero at the start of data
collection. Enter a 1 in this field to enable automatic zeroing. Enter a 0
(zero) for conventional zeroing.
X4 Mode
The resolution of the Rotary Motion sensor can be set to either 1º or
0.25º. When the X4 Mode field is set to 0 (zero), resolution is 1º. When
set to 1, resolution is 0.25º. The X4 mode may not be available with
LabPro.
Diameter
When a linear displacement calibration file is opened for a Rotary
Motion Sensor, a diameter field appears. Enter the diameter of the rotary
wheel so Logger Pro can translate the rotation of the sensor to the
displacement. The units used for diameter will be the units of the
reported displacement.
Data Collection

Data Collection is used to set data acquisition parameters such as
data rate, triggering and mode. You can access the Data Collection
dialog using the toolbar as well.

There are several data collection modes. They are selected from the drop
down menu on the Mode tab.
Real Time Collect
Data are collected at the rate indicated and for the experiment length set
on the Sampling tab.
78

Logger Pro

Logger Pro Reference
Repeat
Data are collected at the rate indicated and for the experiment length set
on the Sampling tab. After a short pause, the run is repeated until the
Stop button is clicked. Usually this mode is used to acquire run after run
while an experiment is adjusted. When a useful run is acquired, press
Stop. If a new run begins before you click on the Stop button you still
can return to the previous run. Click stop, then choose Undo Collect
from the Edit menu.
Events with Entry
A new column is defined to replace the time column. Enter a name for
the column (Column Label), short name, and the column units. Data are
recorded only when the Keep button is clicked. Subsequently the Events
with Entry dialog appears on top of the Keep button. Enter the manual
data and click OK or the Return key to accept.

Selected Events
Data are recorded only when the Keep button is clicked. No manual
entry column is created, and time is the independent variable.
Photogate Timing
Data are collected from a photogate or Smart Pulley. The photogate
mode supports seven methods of collecting data. The various modes are
made available on the Sampling tab of this dialog box.
Radiation Counting
Data are collected from a Radiation Monitor or a Student Radiation
Monitor. The Sampling tab allows the experiment length, mode and the
length of the counting time interval to be set. The Real Time Collect
mode is used for lifetime measurements, while the Events with Entry
mode is used for measuring count rates on user command, similar to the
Events with Entry mode for other sensors described above.
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Sampling

The contents of this tab are determined by the data collection mode.
When using any mode except the Events with Entry, Photogate or
Radiation Counting modes, the following Sampling dialog box will
appear:

Experiment length
Enter the length of time over which data are to be collected. A maximum
of 30,000 total points can be collected over all input channels.
Sampling Speed
Enter the number of measurements per time unit desired. You can also
adjust the sampling speed using the slider.
Over Sampling
When over sampling is set, the actual data collection rate is higher than
set in the sampling speed field, and up to the indicated number of evenly
spaced readings is averaged to create a single data point. The actual
number of points used may be fewer than indicated due to sampling
speed limitations of the interface. Over sampling is not available for
digital sensors such as the Motion Detector, Photogates, or Radiation
Monitor.
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Photogate Sampling

When using the Photogate mode, the following Sampling dialog box will
appear:

The contents of this dialog box will depend upon the selected Timing
Mode. Pull down the Timing Mode list and choose an appropriate mode.
The Timing Device Selection portion of this dialog box is a function of
the timing mode. If the timing mode is Motion Timing, select the type of
device. If you are using a custom device, click the User defined button
and enter the distance in meters between the leading edges of the device.
In other timing modes you will only need to enter the length of the object
that passes through the gate or gates.
Radiation Counting Sampling

When using the Radiation Counting mode, a different Sampling dialog
box will appear:

Radiation
Choose between Real Time Collect and Events with Entry. The Real
Time Collect mode is used for lifetime measurements, while the Events
Logger Pro
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with Entry mode is used for measuring count rates on user command,
similar to the Events with Entry mode for other sensors described above.
Experiment length
Enter the length of time over which data are to be collected.
Count Interval
Logger Pro will count the number of pulses detected during each count
interval. For example, the settings shown above will have Logger Pro
report the number of pulses during each of sixty 5.0-s long intervals, for
a total collection time of 300 s.
Time
Choose a time unit.

Triggering

Data collection can be triggered; that is, data are not collected until
certain conditions are met. To use triggering, click on the Enable
Triggering check box, and enter the desired trigger conditions. Data
collection begins when conditions are met on any one channel. When
data collection rates over 2000 points/second are used, up to 128 points
of data prior to the trigger condition can be acquired. Enter a number in
the pre-trigger field to use this function. When using the LabPro
interface and a fast rate data collection, the dialog is slightly different to
account for the fact that LabPro uses edge triggering at these rates.

Interface

The Interface dialog box allows you to force Logger Pro to search for a
compatible interface. The current communications channel is shown in
the drop-down menu. If the most recently used interface is not detected,
“Select port to scan” appears as the Interface. To choose a channel,
select it from the list. That port will be scanned for an interface.
Successful communication with an interface is shown by the identifying
information; here, a LabPro is connected to COM1. Click on OK to
confirm the search and close the dialog. The next time Logger Pro is
started the selected port will be used. If no interface is detected on the
selected port, the OK button will change to Scan. Use this button to re-
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scan the currently selected port, or click Cancel to leave the dialog
without searching for an interface.

It is only necessary to use this dialog if Logger Pro is started without the
interface connected or powered, or if communication with the interface
is lost.
The interface to which Logger Pro defaults, with no real interface
attached, is controllable. For example, to setup an experiment for a given
interface without being connected to that interface, go to Preferences on
the File menu, choose the Hardware tab, and select the Default Interface.
Window menu

New Tall Window

Æ

New Tall Window creates a new window. The current window is halved
in width and the new window is created beside the resized active
window. A hierarchical menu, New Window has the following choices:
• Graph: Choose Graph to create a data plot.
• Table: Choose Table to create a new data table.

Æ

• FFT: Choose FFT
Graph to create a new Fast Fourier Transform
graph, or subsequently FFT Table to create an FFT table.

Æ
Æ

• Histogram: Choose Histogram
Histogram Graph to create a new
Histogram, or choose Histogram
Histogram Table to create a data
table of the histogram bin counts.
• Text: Text opens a text edit window for comments.
• Meter: Meter creates a window with digital readouts of data.
• ActiveX: Choose ActiveX to create an ActiveX window from
Visualizer, Excel, Netscape, or movie file.
Logger Pro
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New Wide Window

Æ

This feature is not available in the current version of Logger Pro.

Arrange
Replace
Window

New Wide Window creates a new window. The current window is
halved in height and the new window is created below the resized active
window. New Wide Menu has the same hierarchical choices as the New
Tall Window command above.

Æ

Replace Window also shares the hierarchical choice of the above
commands, but instead of generating an additional window, it replaces
the current window with the selected type of window.

Autotile

Autotile is a toggled setting. When checked it forces a tiled layout of
windows whenever a window edge is moved.

Toolbar

Toolbar is a toggled setting. When checked the toolbar is visible on
screen. Uncheck it to hide the toolbar.

1 Graph Window

The title of each open window is listed at the bottom of the Window
menu. Select the title of the window you want on top.

Remote menu
The LabPro interface is capable of collecting and storing data when it is
not connected to a computer. This is called remote data collection. The
Remote menu items are only available when a LabPro interface is
detected by Logger Pro. Extensive information on remote data collection
is shown in the How To section of this manual.
Set Up LabPro

Set Up LabPro will open a dialog box with instructions for preparing
LabPro for remote data collection.

Retrieve Data from LabPro

Retrieve Data from LabPro is used to download data from a LabPro
interface after remote data collection.

Help menu

Contents

Help Contents displays the table of contents for on-line help.

Index

Index displays the on-line help index.

About Logger Pro

About Logger Pro shows the version number and copyright information.

(Windows only)

About (Untitled)

The menu name will change to match the current experiment file.
Choosing this item will open a text entry region for storing notes about
the experiment file. When an experiment file with notes entered here is
opened the notes will be displayed.

About LabPro

If you have a LabPro connected, About LabPro will display the version
number of the LabPro firmware. In addition, the current auto-ID sensor
ID numbers and the auto-ID experiment file in use (if any) is displayed.
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Troubleshooting Guide
Problem
Logger Pro cannot find the
Interface

Cause
Solution
Interface not correctly connected Connect interface to the modem or
to computer
printer port (Macintosh) or COM1,
COM2, COM3 or COM4 (PC) using
supplied cable. On a Macintosh or
PC you may use a USB cable and
port for LabPro.
Two or more copies of Logger
Exit all but the first copy of Logger
Pro running
Pro.
Bad interface cable
Replace interface cable
Wrong serial port being used
Make sure you are using the correct
serial port. For example, don’t
confuse COM1 and COM2 (PC) or
the Printer and Modem ports (Mac).
Interface not receiving power
Make sure the power adapter is
(green light off) or not turned on. plugged into a wall socket and
connected to the interface.
Turn on power switch (ULI only).
Battery-powered LabPro or
Serial Box: Make sure the green
Serial Box has dead batteries
LED comes on when you start up
Logger Pro.
LabPro: Remove and replace a
battery. You should hear tones and a
flashing of all 3 LED’s.
Modem port of Macintosh not
If you are using a Macintosh with an
available
internal modem, make sure that the
control panels are set for external
modem.
If you are using a Macintosh
PowerBook with a single
modem/printer port and are not
using Ethernet port, AppleTalk must
be turned off to make port available.
Computer’s serial port is set up Reconfigure the serial port for use
for internal modem use. (This is with an external modem.
a potential problem for any
computer with an internal
modem.)
Serial port of PC disabled
If you are using a laptop PC, make
sure the serial port is not disabled by
a power-saving mode.
Modem or serial port in use by Quit any other program that could be
another program
using the port, such as a Palm Pilot
or digital camera.
Logger Pro

85

Appendix A
Problem
Cause
The mouse locks up as Logger Logger Pro and a serial mouse
Pro starts up
conflict (PC)

Cannot save a previously
opened experiment file

File has been opened in readonly mode (default).

Sensor not working

Sensor connected to the wrong
port.
Two sensors connected to the
same input line of the ULI.

Sensor faulty

No data appearing in graph

Graph range defined too small
for data to appear

Readings are noisy

Interface is picking up
interference from the computer
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Solution
Hold down the Ctrl key during start
up. The program will not
automatically search for the
interface. Click on the correct COM
port for the ULI.
Clear read-only check-box when first
opening file, or save the altered file
under a new name.
Make sure the sensor is connected to
the correct connector. Refer to the
Sensor Setup in Logger Pro.
Never use more than one sensor
connected to each voltage input at
the same time. For example, if you
are using the DIN 1 socket, do not
use the Port 1 modular phone
connector at the same time.
Try a different sensor. You might
want to try measuring the voltage of
a battery with the Voltage Probe.
Select Autoscale Once or doubleclick on the graph and select a larger
range of values for the axes.
Place the interface at least 30 cm
away from the computer.
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Using Logger Pro on a Network
General principles

If your computers are served software from a central file server on a
network, you can install Logger Pro on the server. Create a folder on the
server to hold Logger Pro (you will need sufficient privileges6 to do
this). Run the Logger Pro Installer from the CD, and specify the file
server folder when the installer asks for the desired location for Logger
Pro. Set the student access rights to the Logger Pro folder to read-only
and shareable. Then students can see and run Logger Pro, but cannot
change it. If students will be setting up sensors themselves or accessing
the Sensor Properties dialog by choosing Sensors… from the Setup
menu or clicking on the interface icon on the toolbar, additional write
access to the calibration files folder is needed.

Logger Pro preferences

Logger Pro will read preferences saved locally on the computer.
Preferences indicate the location of calibration files and the default
location of experiment files. If you want students to use a standard set of
calibration and experiment files, the files should be stored on the server
in a location to which students have the same access privileges as the
Logger Pro program itself. The preferences must then be set to indicate
the location of these files on your server. When you set the preferences,
you must have write access to make changes to the experiment, or
calibration files.
Two good choices for the location of experiment files are 1) A protected
directory on the file server where the students cannot make changes; or
2) A local directory where students can store their own files. In the first
case students must be directed to save files to another directory; in the
latter, experiment files must be placed on each computer and could be
changed inadvertently. To avoid accidental changes, set file attributes to
Read-only (Windows, right-click on file to see dialog) or to Locked
(Macintosh, select file, choose Get Info to see dialog). This way you can
have a reference set of experiment files while students can still save their
own files.
Similarly, calibration files can be stored either centrally on the server or
on individual machines. If your students will use a common set of
calibration files, then choose the former. For the less common case of
individually calibrated sensors (custom calibration done for a specific
sensor/interface/computer combination), then the calibration files must
be stored locally since they will be different for each computer. Lock or
set to read-only those files you do not want changed.

Macintosh

To use the network copy of Logger Pro, log in to the file server so the
server’s icon is on the Macintosh desktop. Locate the Logger Pro icon,
and double-click to start. For simplicity, create an alias for Logger Pro
on the local hard disks. Then, when the alias is double-clicked, the user
will be prompted to log in, the file server disk will be mounted and
Logger Pro will start.

6

File servers provide some security by only allowing certain users to perform
functions like saving, modifying, or deleting files in certain directories.
Typically only administrative accounts are allowed to make changes anywhere
on the server—one speaks of having the privilege or right to make these
changes.
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Windows

To use the network copy of Logger Pro, log in to the file server and
navigate to the Logger Pro icon. Double-click on it to start. As a shortcut
in Windows, you may want to drag the Logger Pro icon to the Start
menu to place Logger Pro in the Start menu list.

Student use of Logger Pro
on a network

For your students to use Logger Pro on a network, they first must have
adequate access rights. In most situations, student access should allow
Logger Pro to be seen and executed, but not changed in any way. Your
network administrator should be able to assist in this setting.
If your students need to change sensor settings or calibrations, they also
need to be able to write files to the Calibration folder. This means they
need rights to create and change files in just the Calibration folder. You
may find the location of this folder by choosing Preferences… from the
Edit menu. Again, your network administrator should be able to assist in
this setting.
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Interfaces Compatible with Logger Pro
You can use LabPro, the Universal Lab Interface (ULI) or the Serial Box
Interface with Logger Pro. The three interfaces differ in capability, but
often any can be used. The Serial Box is a low cost interface lacking
digital and high-speed inputs, while the LabPro can be used for any
sensor and can also be used with TI Graphing Calculators. The ULI is a
computer-only interface that also offers high speed and digital inputs.
The table below will give you the details so you can decide which
interface to use in your experiments.

Which Interface?

Interface

Cost

LabPro

$220

Sensors

Use in…

As fast as
50,000
$65 for Logger readings per
Pro software
second
(includes
Mac/PC site
license)

All sensors

Physics
Chemistry
Biology
Physical Science
Middle School
Integrated Science
Earth Science
Water Quality

Serial Box
Interface

$99

As fast as 50
readings per
$65 for Logger second
Pro software
or
$30 for Data
Logger (both
include site
license)

Two analog inputs
to use with
temperature,
voltage, pH,
pressure, force,
colorimetry, light,
heart rate, EKG,
dissolved oxygen,
conductivity,
magnetic field, and
others.

Chemistry
Biology
Physical Science
Middle School
Integrated Science
Earth Science
Water Quality
but not Physics

Universal
Lab Interface

$220

Four analog and two
digital ports to use
with all of the above
plus motion, ULI
Force, photogate,
radiation.

Physics
Chemistry
Biology
Physical Science
Middle School
Integrated Science
Earth Science
Water Quality

Battery operation

Data Rate

As fast as
11,000
$65 for Logger readings per
Pro software
second
or
$49 for ULI
Software
Package7
(both include
site license)

(except ULI Force
Probe)

The LabPro and Serial Box Interface offer the advantage of battery
operation. Battery operation of LabPro is standard. The Serial Box
Interface requires the Smart Battery Holder (SBI-BAT, $29). Both are
easy to use in the field with a portable computer, and the LabPro
additionally offers remote data collection without a computer attached.

7

Contains Data Logger, Motion, and Sound for 68000 Macintosh or MS-DOS,
plus ULI Timer (Mac only)

Logger Pro
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Appendix D
Sensors for use with Logger Pro
You can use many different Vernier sensors with Logger Pro. The
Logger Pro package includes calibration files for these sensors. Most
sensors can be used with the LabPro, the ULI or the Serial Box Interface;
others can be used only with the ULI.
Sensors supported by all
interfaces

Additional sensors for the
ULI and LabPro

These sensors can be used with Logger Pro and a LabPro, a Serial Box
Interface or a ULI.
• 25-g Accelerometer
• Barometer
• Biology Gas Pressure Sensor
• CO2 Gas Sensor
• Colorimeter
• Conductivity Probe
• Direct-Connect Temperature Probe
• Dissolved Oxygen Probe
• Dual-Range Force Sensor
• EKG Sensor
• Exercise Heart Rate Monitor
• Extra Long Temperature Probe
• Flow Rate Sensor
• Gas Pressure Sensor
• Heart Rate Monitor
• Instrumentation Amplifier
• Ion-Selective Electrodes (Ammonium, Calcium, Chloride, Nitrate)
• Light Sensor
• Low-g Accelerometer
• Magnetic Field Sensor
• O2 Gas Sensor
• pH System
• Pressure Sensor
• Relative Humidity Sensor
• Respiration Monitor Belt
• Student Force Sensor
• Thermocouple
• Turbidity Sensor
• Voltage Probe
• 3-Axis Accelerometer
• Microphone
• Motion Detector
• Photogate
• Rotary Motion Sensor
• Student Radiation Monitor

Sensor for LabPro only

• Stainless Steel Temperature Probe

Sensor for ULI only

• ULI Force Probe

Experiment and calibration
files

Experiment files for all supported sensors are supplied with the Logger
Pro package. These experiment files will automatically load Vernier
Logger Pro
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calibration files for use with these sensors, although other calibration
files may be chosen.
After loading a sensor’s experiment file, Logger Pro will display
appropriate units for that sensor.

Sensor Price List
Sensor
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LabPro
Price/Order Code

SBI or ULI
Price/Order Code

3-Axis Accelerometer

$199 (3D-BTA)

$199 (3D-DIN)

25-g Accelerometer

$91 (ACC-BTA)

$89 (ACC-DIN)

Barometer

$58 (BAR-BTA)

$56 (BAR-DIN)

Biology Gas Pressure Sensor

Use GPS-BTA

$68 (BGP-DIN)

CO2 Gas Sensor

$261 (CO2-BTA)

$259 (CO2-DIN)

Colorimeter

$99 (COL-BTA)

$99 (COL-DIN)

Conductivity Probe

$81 (CON-BTA)

$79 (CON-DIN)

Current & Voltage Probes

$86 (CV-BTA)

$84 (CV-DIN)

Direct-Connect Temperature
Probe

Use TMP-BTA

$28 (DCT-DIN)

Dissolved Oxygen Probe

$191 (DO-BTA)

$189 (DO-DIN)

Dual-Range Force Sensor

$99 (DFS-BTA)

$98 (DFS-DIN)

EKG Sensor

$142 (EKG-BTA)

$140 (EKG-DIN)

Exercise Heart Rate Monitor

$91 (EHR-BTA)

$89 (EHR-DIN)

Extra Long Temperature Probe

$70 (TPL-BTA)

$68 (TPL-DIN)

Flow Rate Sensor

$129 (FLO-BTA)

$128 (FLO-DIN)

Gas Pressure Sensor

$71 (GPS-BTA)

$70 (GPS-DIN)

Heart Rate Monitor

$49 (HRM-BTA)

$47 (HRM-DIN)

Ammonium Ion-Selective
Electrode

$165 (NH4-BTA)

$163 (NH4-DIN)

Calcium Ion-Selective
Electrode

$165 (CA-BTA)

$163 (CA-DIN)

Chloride Ion-Selective
Electrode

$165 (CL-BTA)

$163 (CL-DIN)

Nitrate Ion-Selective Electrode

$165 (NO3-BTA)

$163 (NO3-DIN)

Instrumentation Amplifier

$51 (INA-BTA)

$49 (INA-DIN)

Light Sensor

$45 (LS-BTA)

$39 (LS-DIN)

Low-g Accelerometer

$90 (BAR-BTA)

$88 (LGA-DIN)

Magnetic Field Sensor

$46 (MG-BTA)

$44 (MG-DIN)

Microphone

$35 (MCA-BTA)

$30 (MCA-ULI)

Motion Detector

$64 (MD-BTA)

$65 (MD-ULI)

O2 Gas Sensor

$186 (O2-BTA)

$184 (O2-DIN)

pH Sensor

$74 (PH-BTA)

$72 (PH-DIN)

Pressure Sensor

Use GPS-BTA

$69 (PS-DIN)
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Radiation Monitor

$205 (RM-BTD)

$199 (RM-DG)

Relative Humidity Sensor

$67 (RH-BTA)

$65 (RH-DIN)

Respiration Monitor Belt
(Requires GPS-BTA or
BPG-BTA)

$58 (RMB)

$58 (RMB)

Rotary Motion Sensor

$187 (RMS-BTD)

$185 (RMS-ULI)

Stainless Steel Temperature
Probe

$29 (TMP-BTA)

Use DCT-DIN

Student Force Sensor

$99 (SFS-BTA)

$99 (SFS-DIN)

Student Radiation Monitor

$145 (SRM-BTA)

$138 (SRM-DG)

Turbidity Sensor

$99 (TRB-BTA)

$105 (TRB-DIN)

Thermocouple

$37 (TCA-BTA)

$35 (TCA-DIN)

Vernier Photogate

$41 (VPG-BTD)

$39 (VPG-DG)

Voltage Probe

$9 (VP-BTD)

$7 (VP-DIN)

Water Depth Sampler

$57 (WDS)

$57 (WDS)

Logger Pro

93

Index

94

Logger Pro

Index

Index
A
About Run · 59
ActiveX · 84
Add Zero Button · 58
Advanced tutorials · 13
Analysis functions · 33
Analyze menu · 62
Annotation · 63
Auto-ID · 18
Automatic Curve Fit · 63
Autoscale Once · 15, 74
Axis labels · 50
B
Bar graph · 17, 68
Battery · 89
C
Calibration · 19
Calibration files · 46
Calibration files, default location · 54
Change graph appearance · 15
Clear · 56
Clear All Data · 62
Close · 52
Collect · 57
Collect remote data · 29
Collection · 78
Collection rate · 80
Collision timing · 25
Column Options · 62
configuration, total · 18
Configure data collection · 21
Configure sensors · 18
Connecting line (graphs) · 68
Copy · 56
Correct entries · 27
Creating an experiment file · 46
Curricular material · 45
Cursor controls · 50
Curve fitting · 63
Customize auto-ID · 47
Cut · 56
Logger Pro
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Index
D
Data averaging · 80
Data collection rate · 22, 80, 82
Data menu · 59
Data table functions · 36
Data Table Options · 71
Default Interface · 83
Delete Column · 62
Delete Run · 59
Digital readout · See Meter window
E
Edit cell contents · 51
Edit menu · 56
Enter data manually · 39
Events with Entry · 24, 79
Examine · 62
Experiment files · 45
Experiment files, default location · 54
Experiment length · 22, 80, 82
Experiment menu · 57
Export data · 40
Export Data · 53
F
FFT · 31
FFT options · See
FFT Options · 70
File menu · 52
Firmware · 84
Fit other functions · 34
G
Gate timing · 25
Gate Timing · 25
Graph behavior preferences · 55
Graph Layout · 73
Graph Options · 68
Graph title · 50
Graphical Analysis · 39
Grid · 17, 69
H
Hardware preferences · 55
Help menu · 84
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Index
Help Topics · 84
Hide Run · 59
High Pass Filtering (FFT) · 70
Histogram · 31, 70
Histogram options · 70
How To … · 15
I
Import Data · 52
Installation · 43
Integral · 67
Interface · 82
Interpolate · 35, 63
Introductory tutorials · 13
K
Keystroke Equivalents · 49
L
LabPro auto-ID · 11
Legend · 17, 68
Linear Fit · 63
Linear regression · 33
Live readouts · 57
M
Manual Curve Fit · 65
Manual data entry · 39
Manual fit · 34
Menus · 52
Meter layout · 72
Meter window · 32
Meter window options · 72
Model (Manual Curve Fit) · 65
Modeling · See Manual Fit
Modify Column · 62
Motion timing · 25
N
Network use · 87
New · 52
New Column · 60
New columns · 37
New Wide Window · 84
Logger Pro
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Index
New Window Tall · 83
O
Open · 52
Over Range Autoscale · 55
Over Sampling · 22, 80
P
Page Setup · 53
Paste · 56
Pendulum timing · 26
Photogate · 24, 79
Photogate sampling · 81
Plot one probe versus another · 16
Point protector · 68
Point protectors · 17
Preferences · 40, 54
Print Preview · 53
Print Screen · 53
Print Window · 53
Printing · 40
Printing Options · 53
Prompted data acquisition · 24
Protecting experiment files · 45
Pulse timing · 25
Pulse Timing · 25
Q
Quick Start · 11
R
Radiation · 81
Radiation counting · 27, 79
Radiation counting sampling · 81
Real time data collection · 21
Remote data collection · 29
Remote menu · 84
Remove a sensor · 20
Repeat mode · 21
Repeat mode of data collection · 79
Replace Window · 84
Replay · 57
Rescale · See Autoscale Once
Restore Rows · 56
Retrieve data · 84
Reverse Direction · 77
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Index
Rotary Motion Sensor · 77
S
Sampling · 57
Sampling speed · 22, 80, 82
Save As… · 52
Save calibration · 20
Save data · 40
Scroll · 16
Scroll arrows · 50
Select All · 56
Selected Events · 79
Selected Events Collection Mode · 24
Sensors · 75
Set Axes to Autoscale · 74
Set Up LabPro · 84
Set Up menu · 74
Show Run · 59
Smoothing · 57
Software installation · 44
Sort data · 28
Sort Data · 60
Spreadsheet, copying data to · 39
Statistics · 67
Stop · 57
Store Latest Run · 59
Strikethrough Rows · 51, 56

Æ

T
Table layout · 72
Table options · 36
Tangent · 33, 63
Teacher’s Guide · 43
Text window · 31
Tick mark labels · 50
Time unit · 82
Toolbar · 49, 84
Triggering · 23, 82
Troubleshooting · 85
Turn off input · 20
Tutorial overview · 13
U
Undo · 56
Undo Zoom · 74
Units · 16
USB · 43
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Index
V
View menu · 67
W
Window menu · 83
Window types · 31
Windowing (FFT) · 70
Windows · 31
Z
Zero · 58
Zero Button · 58
Zoom · 15
Zoom In · 73
Zoom Out · 74
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