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Temperature Tutorial

Tutorial: Temperature Measurement
with Logger Pro
About the tutorial

This tutorial will show you how to make simple measurements using a
temperature probe and Logger Pro. You will also learn to perform some
basic analysis of those data. You may never need to learn more about
Logger Pro, but advanced users will want to explore the menus and the
How To section to make the best use of the program’s capabilities.

Verify the equipment setup

First, check to see that you have all of the equipment and software
needed. You should locate these items:
• a PC running Windows® or a Power Macintosh
• Logger Pro software on your computer
• LabPro, Universal Lab Interface (ULI), or a Serial Box Interface, with
power supply and interface cable
• Direct-Connect Temperature Probe, plugged into DIN 1 of the ULI or
Port 1 of the Serial Box Interface. LabPro users can use either of these
probes or the Stainless Steel Temperature Probe, connected to CH 1.
• 2 cups, one with hot and one with cold water

The interface

The interface converts the signals from the temperature sensor to a form
that the computer can read. If you are using a Serial Box or ULI, be sure
that the green light is on. The interface cable should already be
connected to your computer.

Logger Pro

Logger Pro is the software that controls the interface and displays the
results of the temperature sensor measurements. The remaining
instructions will teach you to work with Logger Pro.

Start Logger Pro

Ç Using the method appropriate for your computer, start the Logger Pro

application. (Double-click on the Logger Pro icon, or select Logger
Pro in the Start Menu.)

You should see a screen like the one shown below. If not, then Logger
Pro is having trouble communicating with the interface. Be sure the
interface is getting power so that the green light of the interface is on,
and that the serial cable is plugged into both the computer and the
interface. Try starting again.

Logger Pro
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Screen elements

The Logger Pro screen contains, from top to bottom, the following major
elements: the menu bar, a toolbar containing the Collect button, a graph
window, a data window, and a status bar.

Ç Choose Open from the File menu.
Ç Click on the Tutorials1 folder and click on Open.
Ç Determine which Temperature Probe you are using: the Direct
Connect with brass tube and no box in the cable or the Stainless Steel
with a stainless steel tip.

Ç Depending on which probe you have, choose the file Temperature
Tutorial for the Direct Connect Probe or Temperature Tutorial Stnlss
for the stainless probe. Click on Open to open the file.

Ç You may be prompted to save your data; for now, click on the No
button to load the new file without saving.

1

In Windows 3.1 you will generally see only the first six characters of the full
folder or file name, e.g., _TUTOR~1 for the _Tutorials folder.
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The Logger Pro screen will look like this after you click OK to dismiss
the experiment note:

Start data collection

Ç Click

Collect

on the Logger Pro screen.

Keep the temperature sensor sitting on the table, away from warm things
like the computer. What’s the room temperature? Now breathe on the
sensor and watch the temperature rise. After 30 s data collection will
stop. You can click Collect again to discard the current run and take
more data.
Measure temperature of hot
water

Ç Fill a cup with hot water and another with cold water.
Ç Click Collect .
As data are being collected,

Ç place the sensor in the hot water to measure the temperature. Allow
Logger Pro to complete data collection.

Notice that the sensor does not read the new temperature instantly, but
that it takes a little while to respond. This is a characteristic of the
sensor. About how long does it take for your sensor to stabilize at the
water’s temperature?
Store run

Measure temperature of cold
water

When you get a useful run, you will often want to preserve it for
comparison to subsequent runs. To store your current run, choose Store
Latest Run from the Data menu. These data will be preserved when you
collect additional data. (Note: This action does not, however, save the
data to disk. You do that using the file menu.)

Ç Once Logger Pro stops taking data, store your last run.
Ç Start data collection while the sensor is still in the hot water.
Ç Move the sensor into your cold water after a few seconds of data
have been collected, and allow Logger Pro to complete taking data.

What is the temperature of your cold water?
Prompted data acquisition—
taking discrete data points

Sometimes when you take data with Logger Pro there is some information that you want to enter about each measurement. For example,
suppose you want to measure the temperature of a water sample as you
add warmer water. You might stop, stir, and measure the temperature
after every 10 mL-addition of water. Prompted data acquisition allows
you to enter the volume of added water, and even to graph it. Here’s an
Logger Pro
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example of using prompted data acquisition. Don’t be terribly careful
about the water quantities below; the goal is to see how Logger Pro
works in this mode, not to do a careful scientific experiment.

Ç As before, depending on your type of probe, open the experiment file
Prompting Tutorial or Prompting Tutorial Stainless found in the
Tutorial folder.

Ç You may be prompted to save your data; click on the No button to
load the new file without saving.

Ç Fill a cup about halfway with cold water.
Ç Click Collect .
Notice the Keep button that appears next to the Stop button:

Ç Put the temperature sensor in the water, and stir.
You can see the temperature reading in the status bar, but the value
won’t be recorded just yet.

Ç Once the temperature reading is stable, click on Keep to have Logger
Pro record it.

Notice that Logger Pro is now prompting you for the volume of added
water in the region just right of the Stop button.

Ç Type 0 (zero) in the region right of the Stop button and press Enter.
Ç Add about 10 mL (or a half-centimeter or so) of hot water to your
cup, and stir with the temperature sensor for a few seconds.

Ç Click on Keep, and type 10 for the approximately 10 mL water you
just added.

Ç Keep adding hot water in ~10-mL steps, stirring and recording the
new temperature once the value stabilizes. For the second addition
enter 20 for the water volume, which is the total volume you added
since starting the experiment. Then repeat for 30, 40, and 50 mL.

Ç Click on Stop to end data collection.
Notice that you now have a graph of water temperature as a function of
the volume of added water. You entered the water volume, and time is
not displayed at all.
Quit Logger Pro

To quit Logger Pro,

Ç choose Quit or Exit from the File menu.
You will be prompted to save your data; for now, click on the No button
to quit without saving.
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Tutorial: Analyzing Data
Once you have taken some data with Logger Pro, there are a number of
things you can do with those data to understand them. This tutorial will
teach you how to use some of the analysis features of Logger Pro.

Ç Start up Logger Pro
Ç Choose Open from the File menu.
Ç Select the file Analysis Tutorial from the _Tutorials folder and click
on Open.

You have just loaded sample data to use in this tutorial.

Changing the graph

There are a number of useful ways to display the data gathered by
Logger Pro. You might want to simply change the limits on the y axis to
study a portion of the data. Or, you might want to add a descriptive title
to the graph. You can do both of these by clicking different parts of the
screen.
First, try changing the limits of the y-axis. The numbers at either end of
the axis can be edited.

Ç Click on the 5 at the top end of the y-axis. The number will be highlighted.

Ç Type a 3 to replace it and press enter.
The graph will rescale. You can change the horizontal axis in the same
way.
You can also ask Logger Pro to rescale the graph automatically.

Ç Choose Autoscale from the View menu or click on the
Autoscale button on the toolbar.

The graph now shows the entire range of data.
Change the graph title

You can change the graph title.

Ç Click on the graph title.
Logger Pro

17

Analysis Tutorial

Ç Type in a new title of your choice and click on OK.
Your title is now in place.
Inspecting data

Sometimes you will want to see the coordinates of a particular place on a
graph.

Ç Choose Examine from the Analyze menu, or click on the
Examine button on the toolbar.

Ç Move the pointer along the graph.
Notice the new legend that appears on the graph. Then, as you move the
pointer across the graph, you will see a numerical readout change,
reporting the coordinates of each plotted quantity at the indicated time.
Data table window

As you move the pointer across a graph the data table scrolls to the
corresponding time. Data columns are color-coded to match the lines
drawn on the graphs.
You can turn off the readout floating box and cursor.

Ç Select Examine again from the Analyze menu to turn off Examine
mode. You can also click on the Examine button again to turn off the
mode.

Removing data

To remove a set of data, you can choose Delete Run from the Data menu.
While the mouse pointer is over Delete Run you will see a list of all the
stored data, including the latest run.

Ç Delete all but the latest run now.
Ç Autoscale the graph to reset the y-axis range.
Your graph screen should have only the most recent data plotted now.

Changing what is graphed

Any column of data from a single run can be plotted against any other
column. Time, while usually plotted on the horizontal axis, need not be
plotted at all if it is not appropriate. For example, you might want to plot
velocity as a function of position in some dynamics studies. To do this
you must change what is plotted on one or both axes.

Ç Click on the y-axis label.
18

Logger Pro

Analysis Tutorial
You will see a dialog box with all of the column headings in the data
table available.

Ç Click on the selection boxes so that only the Velocity column is
checked.

Ç Click on OK.
Ç Click on the x-axis label to get the x-axis selection dialog.
Ç Click on the Distance selection button and click on OK.
You should see a plot of velocity as a function of position. Physicists call
this a phase plot. Now you will change the plot back to a conventional
velocity as a function of time graph.

Ç Click on the x-axis label to get the x-axis selection dialog.
Ç Click on the Time selection button and click on OK.
You should see a velocity vs. time graph.
Tangent lines

Logger Pro can draw tangent lines to any curve on screen.

Ç Choose Tangent from the Analyze menu or click on the tangent

button on the toolbar, and point at a portion of the data with the
mouse.

Logger Pro will draw the tangent line at the current mouse pointer
position; its slope is displayed in the legend box. Move the pointer to see
other tangents.

Ç Turn off tangent mode by choosing Tangent from the Analyze menu
again (or you can use the toolbar).

Integrals

Similar to the tangent function, you can integrate your data. To integrate
a region,

Ç select a region of your data by dragging across it with
your mouse.

Two vertical bars should appear to indicate the selected
region.

Ç Choose Integrate from the Analyze menu or
click on the integral button on the toolbar.

The area between the curve and the horizontal axis will
be shaded, and the numerical result displayed in a
floating box as shown here. You can drag the box to any
place on the graph you want. To remove the integral,
click on the upper right corner of the floating box. To
integrate all of the data choose integral with no selection
made in the graph window or data table.

Ç Remove the integral by clicking the upper-right corner of the floating
box.

Statistics

You can also ask Logger Pro to calculate the mean, maximum,
minimum, and standard deviation on part or all of your data. To find
statistics on part of the data,

Ç select a range of data by dragging across it.
Ç Choose Statistics from the Analyze menu. You can also press
the statistics button on the toolbar.

A moveable floating box will appear with the results. To remove the
floating box, click on the upper-right corner of the floating box. For
statistics of the entire data set choose Statistics with no data selected. If
Logger Pro
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you have already selected data, clear that selection by clicking once in
the graph region of the graph. The vertical selection bars will disappear.
Quit Logger Pro

You’ve now learned how to change the graph scale, obtain numerical
data from the graph, draw integrals and tangent lines, and perform
statistical calculations on a data set. Another tutorial will show you how
to fit lines and curves to your data.

Ç Quit Logger Pro by choosing Quit or Exit from the File menu. Do not
save any changes.
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Tutorial: Fitting Lines and Curves to Data
Logger Pro will fit a variety of functions to your data, and then plot the
function and report the fit statistics. This tutorial will lead you through a
number of fitting exercises.

Ç Start up Logger Pro.
Ç Choose Open from the File menu.
Ç Select the file Fitting Tutorial from the Tutorials folder and click on
Open.

You have just loaded some sample data to use in this tutorial.
Fitting a straight line to data

Often data show a linear trend, and you want to know
the slope of that trend. Locate a part of the data that
seem to follow a more or less straight line. It doesn’t
have to be very straight.

Ç Select these data by dragging the mouse pointer
across the region.

Ç Choose Linear Fit from the Analyze menu.
You can also click on the Linear Fit button on
the toolbar.4

Logger Pro now plots the best-fitting line
and displays the fit statistics in a floating
box. Since your selection is not necessarily
the same as used here, your fit parameters
may differ.
Removing a fit

To remove a fitted line and parameters,

Ç click on the close box (the upper right
corner) of the floating box.

Fitting more complex
functions to data

You can also fit more complex functions to
your data.

Ç Select the curved region of data with the mouse.
Ç Choose Curve Fit from the Analyze menu. You can also click
on the Curve Fit button on the toolbar.

A dialog box will open:

4

You can also perform a linear fit using the more general Curve Fit command,
but more steps are required.

Logger Pro
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You can select the desired function from the scrolling list at the lower
left by clicking it. For this example,

Ç choose the Quadratic function from the Function list.
Ç Choose the Distance Latest column from the Perform Fit On list.
Ç Click on the Try Fit button at lower right.
You will see a trial fit drawn on the draft graph. You can modify the fit
as desired by changing the selection range or equation used, and clicking
Try Fit again. Once you are satisfied with the fit,

Ç click on OK to return to the main graph window.
Interpolate

Once you have performed a fit, you can use it to interpolate between
data points.

Ç Choose Interpolate from the Analyze menu.
Move the cursor to the desired region, and read off the coordinates of the
curve from the legend box. Note that you are not reading the coordinates
of the data but of the fitted line.

Ç Turn off interpolate mode by choosing Interpolate from the Analyze
menu again.

Removing a fit

As before, you can remove a fit by clicking the close box of the floating
box.

Ç Remove the fit.
Quit Logger Pro

You have now learned how to fit a line or a curve to your data, how to
interpolate using those fits, and how to remove curve fits.

Ç Quit Logger Pro by choosing Quit or Exit from the File menu. Do not
save any changes.
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How To
In the How To section you will learn to perform specific functions in
Logger Pro, such as using a new sensor or changing data collection
rates. You don’t need to read this section straight through—just jump to
the task you want to perform, and read that portion. The tasks are
organized in seven broad categories: graph appearance, sensor functions,
data collection options, non-graph windows, data analysis, data tables,
and saving and printing data.
If you have further questions, go to the reference section and read the
descriptions of the relevant menu items, or check the index for other
references.

Change Graph Appearance
There are many ways that you might want to change the appearance of
the initial graph. The range of the x or y axis might not be ideal. Or, you
might want to plot other quantities on each axis. You can change most
elements of the graph directly by clicking on them, so if you are not sure
how to change a given item, begin by clicking on it and see what
happens. Here are some things you can quickly change on a graph.
Change axis limits manually

Often you will measure some quantity and the plotted line will only fill a
portion of the screen. You can quickly change the range of values plotted
by clicking the numbers at the ends of the graph axes. Type a new value
and press enter.

Change axis limits
automatically

To make the plotted data fill the graph window, click the
Autoscale button on the toolbar.
To change just the x- or just the y-axis limits, click on the desired axis.
You will see a dialog
box:
Choose the type of
scaling you want.
Autoscale will set the
axis limits so the data
just fill the axis. The
origin
may
not
necessarily
be
included unless you
choose
Autoscale
from 0, in which case
the origin is always included. Manual scaling allows you to enter the
minimum and maximum limits manually. The choice made here will
determine how Logger Pro scales a new graph.

Zoom in on a graph

To enlarge a portion of a graph to fill the screen, drag across the
desired area with the mouse, leaving a rectangle on the graph
enclosing the area of interest. Then click on the Zoom In button on the
toolbar. If you don’t like what you see, you can reverse the action
by clicking the Undo Zoom button.
The Zoom Out button will double the range of both the x and y
axes. It does not undo a Zoom In—Undo Zoom does that.

Logger Pro
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Scroll to a new portion of
graph without rescaling

Sometimes the plotted data will extend off the screen. The arrows at the
ends of the vertical and horizontal axes can be used to scroll across the
data. Using the scroll arrows is equivalent to changing both extremes of
the axis limits at the same time while maintaining the same interval
between extremes.

Change what is plotted

The default plot will usually be the sensor output as a function of time or
a prompted input. You may want to plot some other quantities. Click
either on the x- or y-axis label to get a check box list of all the possible
quantities for plotting. Some combinations will not be useful. If you
don’t see what you want to plot, you may be able to create a new column
of data based on the raw data. See create new columns below. Once
you’ve defined a new column you can plot it.

Graph two or more sensors
simultaneously

You can plot data from multiple sensors either on a single graph or on
separate graphs. To use a single graph:

Ç Click on the y-axis label and select all the sensors you want to plot
together. Click on OK

To use several different graphs, you need to create the needed number of
graph panes:

Ç Choose Graph Layout from the View menu.
Ç Click on the layout with the desired number of panes.
Ç For each graph click on the axis label for a list of available columns
for plotting. Choose the column of the desired sensor.

Plotting one sensor versus
another sensor

Sometimes it is appropriate to plot the value of one sensor versus
another. For example, you might want to graph pressure as a function of
temperature. Once Logger Pro is set up to simultaneously take data for
the two sensors, click on the axis labels to select the appropriate
quantity. A graph does not need to include time.

Arrange windows

This feature is not available in the current version of Logger Pro.

Change the units displayed

The axis labels are shown with physical units whenever they are
available. When you set up a new sensor, you can enter the desired units
at the same time that you perform calibration. For more information see
sensor setup below.

Change other graph options

If you double-click on a graph, you will get a dialog box that allows you
to change a number of graph options. Brief descriptions follow; for
additional information see Logger Pro reference.
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The following functions are found on the Graph Options dialog. Double
click a graph to open this dialog box.
See data points directly (point
protectors)

Select point protectors as desired. A point protector outlines a data point.
You may want to outline every 5th or 10th point to keep the graph from
getting crowded.

Add/remove a legend

Adding a legend opens a floating box holding a key to the plotted data.

Connect data points

Select the Connecting Line option to connect data points with lines.
Without this option selected individual data points are visible.

Bar graph

When this option is selected a line is drawn from the horizontal axis to
each data point, creating a bar graph. You can control the width in
pixels. Setting the 3D checkbox adds simulated depth to the bars.

Add/remove the grid

Select or deselect the grid as desired. You can also adjust the line style
and color of the gridlines in this dialog box.

Graph title

Select or deselect the Graph Title option as desired. Logger Pro attempts
to create a title for a graph based on the axis labels, but you can override
the automatic title by entering text in the Graph Title field.

Logger Pro
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Configure Data Collection Options
The easiest way to configure Logger Pro for a particular data collection
mode is to open the appropriate experiment file. Experiment files for all
compatible sensors and common data collection modes are supplied with
Logger Pro. You can also configure Logger Pro manually. Instructions
for manual configuration follow.
Collect data in real time

Choose Data Collection from the Setup menu. You will see this dialog
box.

Select Real Time Collect from the scrolling list. In this mode data are
collected continuously at the rate indicated and for the time interval set
on the Sampling tab. To modify these settings, click on the Sampling
tab.
Collect data repeatedly

To start new data collection runs repeatedly, select Repeat from the drop
down menu. Logger Pro will collect a data run, pause for a moment, and
then collect another run, overwriting the previous run. To stop data
collection, click on the Stop button on the Toolbar. If you miss the end of
a run you want to keep and Logger Pro starts taking data again, click on
stop, then choose Undo Collect from the Edit menu to return to the
previous run.

Logger Pro
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Set sampling speed
(data collection rate)

In the Data Collection Sampling tab set the time units you want and the
Sampling Speed, i.e., the number of points collected each second,
minute, or other time interval. Sampling speed is a trade-off; too fast a
speed yields unwieldy data sets, while too slow a collection rate will
miss important experimental details. Logger Pro can collect at most
30,000 points in each input channel.

Set experiment length

Set the total time of data collection for Real Time Collect, Repeat and
Selected Events modes in the Data Collection Sampling tab. You can
also set the experiment length by changing the maximum time axis label
to the desired value.

Set time units

To set the units used on the time axis, choose between hours, minutes,
seconds, and milliseconds in the drop down menu.

Set averaging

The setting on the Averaging tab determines how many measurements
will be taken for each reported point. For example, if the sampling speed
is 10 samples/second and the averaging is set to 5 points, readings will
be taken 50 times a second (evenly spaced in time) and 5 will be
averaged to yield a single data point. Click OK to enter your settings.
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Only analog sensor readings can be averaged. Digital readings such as
from the Motion Detector cannot be averaged.
Smooth existing data

Æ

You can define a new, smoothed data column as a function of an existing
column using the smooth( ) function. Choose New Column
Formula,
enter a name, click the definition tab, and in the equation field enter
smooth(“column name”) where column name is the name of the
existing data column. Click OK to create the new column. Smoothing
differs from averaging in that smoothing acts on an existing data column
and does not reduce the number of data points.
To change the number of points used in smoothing choose Options in
the Experiment menu. The subsequent dialog box allows you to vary the
amount of smoothing. Excessive smoothing will obscure details in the
data.

Trigger data collection

The Triggering tab of the data collection dialog allows you to set trigger
conditions for data collection. When triggering is enabled in the
checkbox and the Collect button clicked, Logger Pro waits until trigger
conditions are met to collect data. If multiple sensors are in use, data
collection will begin when the trigger condition is met on any one of the
inputs. Only analog sensors can be used for triggering.

Logger Pro
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Collect data point by point
(prompted)

To collect discrete data points rather than a steady stream of data, choose
Data Collection from the Setup menu. Choose either Events with Entry
or Selected Events from the drop down menu. In either mode, after the
Collect button is clicked a Keep button appears. A data point is recorded
whenever the Keep button is clicked; in addition if the mode is Event
with Entry you are prompted to enter values for a new data column. For
example, you might enter a volume, concentration, or trial number. The
labels for the prompted column are entered in this dialog box.

Collect photogate data

To collect photogate or Smart Pulley data, choose Data Collection from
the Setup menu. Choose Photogate Timing from the drop down menu on
the Mode tab. It is not necessary to set any inputs using the Setup Sensor
dialog. The photogate mode supports seven methods of collecting data.
To see these modes click the Sampling tab:

The available modes are: Motion Timing, Gate Timing - One Gate, Gate
Timing - Two Gates, Pulse Timing, Collision Timing, Pendulum Timing,
24
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Tutorial: Saving Files, Printing,
and Transferring Data
Once you get some useful data, you may want to save them to a floppy
disk or a hard disk for future use, print them, or transfer them to another
application such as a spreadsheet. This tutorial will show you how to do
these things with some sample data found in a file. To load the file,

Ç Start up Logger Pro
Ç Choose Open from the File menu, and locate the file Fitting Tutorial
in the Tutorials folder.

Note the field at the bottom of the dialog box marked Open as read-only.
When this box is filled (the default), the Save command and the Save
toolbar button are disabled in order to protect the original file. Usually
you will want to save files under new names using Save As…. Leave the
check box filled.

Ç Click on Fitting Tutorial to select, and click on Open.
Saving an experiment file

It is very useful to preserve the current state of Logger Pro in a file. For
example, you might configure Logger Pro to carry out a particular
experiment, perform a calibration, and take some sample data. All the
work just done can be retrieved later by opening a file. Such an
experiment file contains the entire Logger Pro state: the sensor
configuration including calibration (either from file or custom), the
graph setup, and any data just collected or stored.
As an exercise, you will save a copy of the experiment file you just
opened to a floppy disk.

Ç Insert a formatted floppy disk into your computer.
Ç Choose Save As from the File menu.
Ç Navigate to the floppy disk drive by using the drop down menu at the
top of the dialog box. Scroll to the floppy disk drive and select it.

Logger Pro
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You will be prompted to choose a file name and a location for the file.
Be sure you know in what folder you are about to save the file. Ask your
instructor if you’re not sure where to put the file.

Ç Enter a file name other than Fitting Tutorial5.
Ç Click on the Save button to save your file.
Retrieving an experiment file

After saving the experiment to disk, you can retrieve it by choosing
Open from the File menu as you did at the beginning of this tutorial. It is
not necessary to do that now.

Printing a graph

When you get a graph the way you like it, you can print it.

Ç Click on the graph window to select it.
Ç Click on the printer icon on the toolbar.
Ç Click on Print or OK as appropriate for your computer.
Your graph will be printed.
Printing data

You can also print a data table by selecting it and clicking the printer
button, but be careful. It is easy to acquire many pages of data. You may
want to reduce the number of data points collected when setting up the
experiment. The print preview command in the file menu will show
what will be printed.

Transferring data to other
applications

You may want to copy data to a spreadsheet or a graphing program.

Ç Click on the All button in the upper left of the Data Table Window to
select the data.

Ç Choose Copy from the Edit menu.
In a moment you will switch to the receiving application. You do not
need to quit Logger Pro; in fact it is much easier if you leave Logger Pro
running so you can return to it later.

Ç Start up or switch to the receiving application.
Ç Position the insertion point or active cell in the upper left of the
region where you want your data to be placed.

Ç Choose Paste from the Edit menu.
Your data will be placed in the receiving application, ready for further
analysis.
Quit Logger Pro

You have now learned how to save an experiment with its data to a file,
to retrieve such a file from disk, and how to transfer data to another
application.

Ç Quit Logger Pro by choosing Quit or Exit from the File menu. Do not
save any changes.

Ç Locate the experiment file you saved earlier and delete it (not the
Fitting Tutorial file).

5

In Windows 3.1 you are limited to file names of eight characters or fewer.
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